Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

FYI: My Netbook model is HP Mini 210-1004sa, which comes with Intel Graphics Media Accelerator 3150, and has a display 10.1" Active Matrix Colour TFT 1024 x 600.

I recently removed Windows 7 Starter from my netbook, and replaced it with Ubuntu 12.10.

The problem is the OS doesn't seem to recognise the native display resolution of 1024x600 i.e. the bottom bits of Ubuntu is hidden beneath the screen & the only 2 available resolutions are: the default 1024x768 and 800x600.

I've also thought about replacing Ubuntu with Lubuntu or Puppy Linux, as the system does run a bit slow, but I can't, as then I won't be able to access the taskbar and application menu which will be hidden beneath the screen. Only Ubuntu with Unity is currently usable, as the Unity Launcher is visible enough.


I was able to define a custom resolution 1024x600 using the Q&A:

but when I set that resolution, there appears a black band at the top of the screen and the desktop area is lowered, with bits of it hidden beneath the screen. I tried leaving it at this new resolution and restarting the system to see if the black band would disappear & the display will fit correctly, but it gets reset to 1024x768 at startup and displays following error:

Could not apply the stored configuration for monitors

none of the selected modes were compatible with the possible modes:

Trying modes for CRTC 63
CRTC 63: trying mode 800x600@60Hz with output at 1024x600@60Hz (pass 0)
CRTC 63: trying mode 800x600@56Hz with output at 1024x600@60Hz (pass 0)
CRTC 63: trying mode 640x480@60Hz with output at 1024x600@60Hz (pass 0)
CRTC 63: trying mode 1024x768@60Hz with output at 1024x600@60Hz (pass 1)
CRTC 63: trying mode 800x600@60Hz with output at 1024x600@60Hz (pass 1)
CRTC 63: trying mode 800x600@56Hz with output at 1024x600@60Hz (pass 1)
CRTC 63: trying mode 640x480@60Hz with output at 1024x600@60Hz (pass 1)
Trying modes for CRTC 64
CRTC 64: trying mode 1024x768@60Hz with output at 1024x600@60Hz (pass 0)
CRTC 64: trying mode 800x600@60Hz with output at 1024x600@60Hz (pass 0)
CRTC 64: trying mode 800x600@56Hz with output at 1024x600@60Hz (pass 0)
CRTC 64: trying mode 640x480@60Hz with output at 1024x600@60Hz (pass 0)
CRTC 64: trying mode 1024x768@60Hz with output at 1024x600@60Hz (pass 1)
CRTC 64: trying mode 800x600@60Hz with output at 1024x600@60Hz (pass 1)
CRTC 64: trying mode 800x600@56Hz with output at 1024x600@60Hz (pass 1)
CRTC 64: trying mode 640x480@60Hz with output at 1024x600@60Hz (pass 1)

Update

Making progress!

I tried setting nomodeset, i915.modeset=1, and i915.modeset=0, respectively; in Grub.

With nomodeset in Grub, I can now see, and permanently set the 1024x600 resolution I created much earlier without any errors. However, the display is squished, and the bottom bit of the OS is still hidden beneath the screen, & I think it has something to do with aspect ratio. I think it might have something to do with the fact that 1024x600 is the only mode with aspect ratio set to 16:9. How do I change it to 4:3 so it fits?

Though slightly insignificant, it is worth saying that with nomodeset enabled, the OS graphics is a bit slower.

share|improve this question
    
I'd have a go at installing Ubuntu 12.04LTS just to see if that works. I had 12.04 on my netbook with no problems, and even upgraded to 12.10. –  Ross Fleming Oct 31 '12 at 13:51
    
I tried running Ubuntu 12.04LTS on USB, and the OS still runs down the bottom of the screen. Also, I'll remind you that this issue is the same with Lubuntu and Puppy Linux; it seems to be a "Linux thing" –  Emmanuel Oct 31 '12 at 14:37
    
1024x600 works fine on my MSI 135 netbook in both Ubuntu 12.04 and 12.10's live media. –  ubfan1 Nov 3 '12 at 22:16
    
For Windows that have bits hidden beneath the screen, I use ALT + left click + drag, to move appropriately. –  Emmanuel Nov 5 '12 at 2:21
    
@Daniel - now that you can change to a 1024x600 resolution - can you try another Desktop Environment such as lubuntu-desktop or xubuntu-desktop - reason - to see if the remaining issues you are seeing are compiz related. –  fossfreedom Nov 6 '12 at 16:13
show 1 more comment

3 Answers

Hi I was just wondering have you tried adding "nomodeset" to grub?

Here is a good reference -> How to set NOMODESET and other kernel boot options in grub2

Let me know how you get on :-)

share|improve this answer
    
After doing this & restarting the system I can now see, and permanently set the 1024x600 (16:9) resolution I created much earlier without any errors. However, the display is squished, and the bottom bit of the OS is still hidden beneath the screen, & I think it has something to do with aspect ratio. The other 2 resolutions are 4:3, whilst 1024x600 mode is 16:9. How do I change it to 4:3? –  Emmanuel Nov 6 '12 at 1:39
    
Hello Daniel sorry for the delay in responding to you, I'm glad to hear that progress has been made with the usage of nomodeset. Could you please add your current xorg.conf to the original post :-) –  Paddy_NI Nov 12 '12 at 12:09
add comment

Have you installed the Intel GPU drivers?
With correct drivers, your GPU may be able to recognize the resolution.

share|improve this answer
    
No I haven't installed any drivers. I found this Intel driver PPA link but nothing seems to be available for Ubuntu 12.10. Will it install properly if I use the PPA for Ubuntu 12.04? –  Emmanuel Nov 5 '12 at 1:57
    
I followed this guide link to install the GPU driver, but the system reports the newest version is already installed. –  Emmanuel Nov 5 '12 at 2:12
    
Have you done anything with the /etc/X11/xorg.conf file? This file is responsible for things like this so try editting it to the correct resolution. –  Cheiron Nov 5 '12 at 7:13
    
That file doesn't exist in the given folder. –  Emmanuel Nov 5 '12 at 9:18
add comment

Install gnome 3 by going to ubuntu software center and installing gnome shell(if you want all the programs that come with Gnome, install Gnome desktop instead of gnome shell) Since gnome has only top panel in the usual view, resolution won't be a problem. Make sure to select GDM as display manager when the system asks you.

share|improve this answer
2  
This doesn't solve the native resolution problem, although I installed Gnome Shell 3 and it's even worse; as some the dash are hidden beneath the screen. PS: I made sure not to select GDM as display manager; it really sucks! –  Emmanuel Nov 3 '12 at 10:40
    
@Daniel - fully agree with you - gnome-shell and GDM are perhaps not the best fit with a lower powered netbook. Lubuntu-netbook is probably better - but the screen res issue needs to be resolved first. Hope you get your answer before the bounty finishes. –  fossfreedom Nov 3 '12 at 12:55
    
@fossfreedom I hope so too, have updated the question to be as clear as possible. –  Emmanuel Nov 3 '12 at 19:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.