Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I had upgraded everything was ready on the screen om my computer and with my 12.04 ubuntu.

When I restarted my system, the graphics card was not detected. I was forced to start the computer in low graphics mode, and eventually I had a pink deskop with only my maps, and no other programs at all.

What do I do now? I need to recover the pictures on my system so that I can upload them online.

I'd done a graphics card test on the terminal initially, and it showed that the card was compatible with unity 3D. I have an ATI radeon HD 3450 and I was running a 32 bit build of Ubuntu 12.04 initially

Right now I have a broken install of Linux, with no working graphics card or desktop to start from, so I'm unsure of how to fix this.

share|improve this question

Ati has removed support for Radeon 2xxx, 3xxx and 4xxx series of graphic cards for their newest drivers, which Ubuntu 12.10 now uses. You need to install AMD's legacy drivers to use these older cards. Here is a blog post which gives several ways to do this. The post's recommended solution, and what worked for me, was to use a 3rd party repository provided by Tomasz Makarewicz. It just required 4 terminal commands.

First though, you need to be able to get access to your applications. Unity glitches under this problem, removing access to the dash, so you should switch to using the GNOME classic desktop environment. You can do this from the login screen, after booting your computer. Click on the small icon to the right of your name, and you should see a dropdown list of desktop options. Select GNOME Classic (No effects). Then logon as usual. You should now have an "applications" menu in the upper left corner of your desktop. Most applications should be in obvious places. To get to the terminal, follow the menu path Applications > Accessories > Terminal.

To install the legacy drivers using Makarewicz's repository, open a terminal and enter the following commands. The first command will require your sudo password, and will also give you a text dump explaining what's going on.

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

Then restart your computer. Your graphics problems should be fixed.

share|improve this answer
An extra note. If you switch to GNOME classic mode, Ubuntu will remember on later boots. You'll have to re-select Unity next time you log in if you want to regain the modern Ubuntu desktop. – Caleb Nov 5 '12 at 18:16
One more comment, for those new to the idea of a "3rd party repository". This is a repository completely unsupported by AMD or Ubuntu. You are implicitly trusting whoever made it to be both competent and non-malicious. That said, as far as I can tell the person who is supplying the fglrx-legacy repository is just trying to be helpful, and it worked magically out of the box for me. Just keep in mind there is some inherent risk installing this. If you want complete peace of mind, you can try some of the more involved options discussed in the blog post I cited. – Caleb Nov 5 '12 at 18:25
ppa:makson96/fglrx not suport HD 3xxx series – Francisco Rocha Dec 15 '12 at 11:21
@FranciscoRocha I think it does support them. It worked for my Radeon HD 3850, and on the ppa site it says: "This repository provides AMD Catalyst drivers for legacy graphics Radeon HD 2xxx - 4xxx" – Caleb Dec 15 '12 at 17:47
This doesn't seem to work for Trusty 14.04 :( – Someone13 Aug 7 '14 at 10:37

It appears that in the recent versions of their proprietary driver AMD dropped support for Radeon 2xxx, 3xxx and 4xxx series of graphic cards. As a result, the new fglrx driver shipped with Ubuntu 12.10 is not compatible with those cards.

You need to uninstall the proprietary driver and use the open-source driver instead.

To uninstall the fglrx driver (more details):

sudo apt-get remove --purge xorg-driver-fglrx fglrx*
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri fglrx-modaliases
sudo dpkg-reconfigure xserver-xorg

I don't have an ATI card so I can't test the steps. You can find more info at Ubuntu Wiki: Proprietary driver, Opensource driver

share|improve this answer

Take a deep breath. Calm down.

Here's what we're going to do - save all your personal settings and reinstall ubuntu from scratch.

Now go find or burn a copy of ubuntu, 12.10 will do, or 12.04, and a USB drive. Boot into it.

Now you have a working linux install from the livecd(I hope!), and you will need to open the drive with your old install of linux. This should be automounted, if not, comment and I will edit to tell you how to access it.

You need to copy the contents of /home from the old install (this should show up as a drive or drives in the livecd)- Copy everything as this contains any settings specific to your install, and a good chunk of your personal preferences. Upload what you want to, now. Copy anything else you need. Ideally you'd also want to retrieve a list of what additional stuff you have installed, but I can't remember how to do that off hand from another install. If you can't read /home, it gets tricky, and you'd selected an encrypted partition. There's probably a way to access it, but that might need you to boot into the old install, and use the command line.

Now comes the slightly scary part. Its too much work to fix a borked upgrade. Wipe and reinstall those linux partitions as per normal, with the same usernames. Copy /home back in place (i'd probably leave out anything specific to unity, or if I REALLY wanted to play it save probably copy just the desktop folder and some directories starting with a . - these are hidden directories with program specific files). Boot into the new install and install whatever packages you need.

share|improve this answer

Reinstalling the whole system will maybe fix it, but it's not necessary. Press Ctrl+Alt+F1 after boot to get to a terminal.

sudo apt-get purge fglrx fglrx-amdcccle
sudo reboot

This should revert to the non-proprietary video drivers (which should be slower, but work).

If the Unity desktop boots OK and you want to reinstall the proprietary video driver: Write "Software Sources" in the Dash, start it, goto the "Additional drivers" tab and choose the fglrx driver. (NOT the fglrx-updates.) Reboot.

share|improve this answer
(The proprietary driver may not support your ATI card.) In that case stay with the non-proprietary (open-source) driver. – Jan D. Nov 3 '12 at 13:27

I am new to Ubuntu and installed it a week ago on my Dell dimension 4600 with an ATI HD Radeon 3450. I tried the linux option from AMD, amd-catalyst-13.12-linux-x86.x86_64 which did not work for my system. After reinstalling I tried the option given by Caleb which worked for me and stopped there.

Although in my research I stumbled upon another solution which I wanted to give a try if this would have failed.

The WIKI from the unofficial linux community (:// points that the newest Linux driver ( does not support the RadeonHD series 20xx-40xx. And they refer to an older driver (, unfortunately the links are broken and it is not downloadable from the AMD-site

But, I did find the driver here As said I have not tried this option. Also I do not know if this download can be trusted. In case I would need this driver I have downloaded it.

I hope someone will use the driver and is able to tell if it will work well

share|improve this answer
Note: I had a clean new installation. Installed 10.04 desktop, installed ATI driver from the upgrade manager, upgraded to 12.04 and then followed the command lines from this thread. – Ubuntu_N00B Mar 14 '14 at 23:38

See this thread for your solution:

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – fossfreedom Nov 4 '12 at 22:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.