Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.10 formating the HDD. Any time that I turn on the PC and boot Ubuntu, it always analyzes my HDD in search for bad blocks. This is what happens: When I turn on the PC and load Ubuntu, before I can login my user, appears the following image. If I press C, the process ends and I can work, if I wait until the process can finish by itself also I can work.

IMG

Also I had this problem, related to the HDD.

My Hard Disk Driver is a Western Digital.

Is there any problem on the system? Can I stop this procedure?


Information that can help: tune2fs -l output

share|improve this question
    
You will have to be more specific. –  psusi Oct 31 '12 at 1:38
    
@psusi You're right but I don't know what information can I add. Tell me what information should I include. –  Lucio Oct 31 '12 at 15:43
    
What does "analyzes my HDD in search for bad blocks" mean? Please describe exactly what you see that makes you think this. –  psusi Oct 31 '12 at 19:00
    
@psusi I upload a picture to help you. –  Lucio Oct 31 '12 at 22:50
add comment

3 Answers 3

up vote 4 down vote accepted

I solved the problem converting the file system from ext2 to ext4.

If you have the same problem, the first thing to do is discover what is your file system with sudo parted -l . If it is ext2 you should convert this to ext4. Review this question where you will find useful information related this procedure.

NOTE: You wont lose data converting your file system (if you do it well without problems..)

share|improve this answer
add comment

Check of the filesystem means, that the filesystem was either not unmounted correctly, i.e. make sure that you shut down your computer correctly (sorry, I had to say this for completeness)

or

that the check is "due". An ext filesystem will be checked for errors regularly, either every x days or every y mounts (i.e. boot processes).

Use for example sudo tune2fs -l /dev/sda1 to display the parameters, including checkup cycles, of the ext filessytem of your first hard disks first partition (/dev/sda1). I don't know how often you reboot your computer. But if you are used to leave it running for several month, it would be quite normal that the check is due with the next reboot. You can manipulate the checkup cycle by using tune2fs -i or tune2fs -c, see man tune2fs for details. tune2fs is the service program for ext2, ext3 and ext4 filesystems, the latter one is afaik the standard file system for contemporary ubuntu installations.

share|improve this answer
    
Of all the info that tune2fs -l show me, I see this option as the most important: Check interval: 0 (<none>). So the system should not check my HDD always. –  Lucio Oct 31 '12 at 15:42
    
what about maximum mount counts? A check can be mount-count based or interval based, as you said correctly the latter is not the case here. –  Paul Hänsch Oct 31 '12 at 16:40
    
I update my ask with all the information of the tune2fs command. The Mount Cont: 1; The Maximum mount count: 30 –  Lucio Oct 31 '12 at 22:56
add comment

That is just a filesystem check, or fsck; it has nothing to do with bad sectors. Based on your tune2fs output, it appears that you chose to format your disk with the ext2 filesystem rather than ext3 or ext4. You should reinstall and use the recommended/default ext4 filesystem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.