Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried everything from this question and this question and I have nothing. I have an asus K50IJ and I just can not seem to get head phones working solo.

According to lspci I have

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

I am running Ubuntu 10.10.

share|improve this question
    
Can you clarify what you mean by "working solo"? Thanks. –  jrc03c Jan 12 '11 at 5:31
    
Same problem here. Any solution? I keep searching –  gabitogol Jan 14 '11 at 16:48
    
this is a bug in alsa's HDA Intel driver - it needs some configuration options added to the conf file - if an alsa expert doesn't give you the flags I will try to dig them up for you. –  RolandiXor Jan 14 '11 at 18:38
    
fortunately i'm not the only one... –  user9088 Jan 18 '11 at 14:17

4 Answers 4

I have the same problem and I use a "simple hack" to solve this issue:

To listen to your headphones only, go to Sound Preferences --> Output and from the "Connector" dropdown Choose "Analog Headphones". When you want the sound back to your speaker go back and select the option "Analog Speakers".

(yes, I know it's stupid, but at least I can listen to my headphones without disturbing other persons in the room)

share|improve this answer
    
I have tried this and it doesn't work. I actually get no sound then. –  MrStatic Jan 14 '11 at 22:59

Perhaps a bit of thread necromancy, but an answer I found with my Ubuntu 10.10 system, with the joys of PulseAudio installed ..

The "Analog Headphones" setting didn't provide any sound anywhere for me, but I found that both ports were active when I selected "Analog Speakers". So now I just turn my speakers off and put the headphones on when I want headphones (Skype, etc). No auto switching, but it's workable for me!

(PS the AudioEngine A2s are surprisingly fantastic! :)

share|improve this answer

You may want to try the steps on http://ubuntuforums.org/showthread.php?t=1811178

It resolved the issue in my Acer Aspire One machine.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Stefano Palazzo Feb 6 '12 at 13:00

I came here with the same problem, I use Ubuntu 11.10, and some hours ago, I installed Xfce to try it. When I went back to Unity and tryed listen to music, the speakers and headphones were working simultaneously. Then I remembered I had that problem some time ago, and I hardly remembered I fixed it removing PulseAudio and installing Alsamixer. In this case I already had installed alsamixer, then I went to the terminal and used the command alsamixer, then I press F6 to select the apropiate sound car, then move with the arrows until select Auto-Mute, it's very probably you will find it Disabled, just turn it to Enable and the problem will be fixed... Excuse for my bad English... I hope my answer help you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.