Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running 12.04 LTS on a VM. I encountered a problem with the screen being black and the familiar orange background showing for a fraction of a second when clicking or resizing the screen. I had to shutdown the machine and now I have no GUI. I only get a black command-line interface.

As some other posts suggest, I attempted:

sudo service lightdm restart

This doesn't work for me because it gets stuck at this point:

Skipping profile in /etc/apparmor.d/disable: user.bin.firefox
Skipping profile in /etc/apparmor.d/disable: user.sbin.rsyslogd
* Starting AppArmor profiles                                        [ OK ]

Any ideas?

EDIT: /var/log/lightdm/lightdm.log:

[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.2.1, UID=0 PID=933
[+0.00s] DEBUG: Loaded configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: Registered seat module xlocal
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Adding default seat
[+0.00s] DEBUG: Starting seat
[+0.00s] DEBUG: Starting new display for greeter
[+0.00s] DEBUG: Starting local X display
[+0.35s] DEBUG: X server :0 will replace Plymouth
[+0.44s] DEBUG: Using VT 7
[+0.44s] DEBUG: Activating VT 7
[+0.44s] DEBUG: Logging to /var/log/lightdm/x-0.log
[+0.64s] DEBUG: Writing X server authority to /var/run/lightdm/root/:0
[+0.64s] DEBUG: Launching X Server
[+0.65s] DEBUG: Launching process 960: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch -background none
[+0.66s] DEBUG: Waiting for ready signal from X server :0
[+0.66s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.66s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.70s] DEBUG: Process 960 exited with return value 127
[+0.70s] DEBUG: X server stopped
[+0.70s] DEBUG: Removing X server authority /var/run/lightdm/root/:0
[+0.70s] DEBUG: Releasing VT 7
[+0.70s] DEBUG: Stopping Plymouth, X server failed to start
[+1.34s] DEBUG: Display server stopped
[+1.34s] DEBUG: Stopping display
[+1.34s] DEBUG: Display stopped
[+1.34s] DEBUG: Stopping X local seat, failed to start a display
[+1.34s] DEBUG: Stopping seat
[+1.34s] DEBUG: Seat stopped
[+1.34s] DEBUG: Required seat has stopped
[+1.34s] DEBUG: Stopping display manager
[+1.34s] DEBUG: Display manager stopped
[+1.34s] DEBUG: Stopping daemon
[+1.35s] DEBUG: Exiting with return value 1

x-0-greeter.log

x-0.log

share|improve this question
    
We need your lightdm log files, please post at least /var/log/lightdm/lightdm.log so we can see why no display is starting. The other logs in that directory may also be needed. –  mfisch Nov 10 '12 at 21:23
    
Added logs as edit. –  mdobrinin Nov 12 '12 at 16:38

2 Answers 2

Your lightdm log states that it can't start X and your x-0.log complains about a missing library. Try installing libxfont1, but I suspect you may be missing other stuff.

[+1.34s] DEBUG: Stopping X local seat, failed to start a display

/usr/bin/X: error while loading shared libraries: libXfont.so.1: cannot open shared object file: No such file or directory

To install it:

sudo apt-get install libxfont1
share|improve this answer

I had this issue after enabling an experimental Nvidia driver. If you think you have the same issue:

  • on boot, type Ctrl-Alt-F1 to get command prompt.
  • to check if you have the nvidia module installed type lsmod | grep nvidia if there is output then you have nvidia installed, otherwise this is not a solution that will work for you
  • remove the nvidia module with sudo rmmod nvidia
  • restart lightdm with sudo service lightdm start
  • you should soon see the login screen. If you don't, then this solution can't help you.
  • for me, once I booted successfully, I had to remove all of the nvidia drivers through settings->additional drivers (I had all experimental additions installed). Otherwise when I restarted I would have the same problem and have to do the above every time
  • once I removed all the drivers, I rebooted and didn't have any issues. Then I enabled the default nvidia driver, restarted, and everything's good!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.