Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed the latest version of Ubuntu (32bit) on the latest version of VMware player. unfortunately the VMware tools didn't install successfully.

Now, when my machine powers up, I'm getting to the login prompt (console, no desktop). I tried installing VMware tools manually but didn't succeed.

Anyway, I tried getting into the Ubuntu desktop, I entered startx and it came right up but there are no icons and no menus. Only the wallpaper with a cursor and when I start typing, I have a small input field on the bottom right area of the screen.

How can I make the icons and menu appear? Is that have anything to do with VMware tools? How can I make the desktop the default login?

share|improve this question
1  
Since this is a VM, I would probably just re-install it. The VMware Tools edit your xorg.conf file, which is probably where things went wrong. Ubuntu comes with a few VMware drivers already installed, so you might make sure that what you need is not already there before going through the tools headache (they are really a pain in the ass to install). –  Bailey S Oct 30 '12 at 21:23
    
I've already tried reinstalling VMware tools and Ubuntu but I'm getting the same error :-/ –  Shai Oct 30 '12 at 21:26
    
You misunderstand, reinstalling VMWare tools will not help you. You need to do a fresh install of Ubuntu in a fresh VM. Afterwards, realize that installing VMWare tools again will do the exact same thing, so you either need to find a more compatible version of the tools, or do not install VMWare Tools. Remember, VMs are pretty disposable, and you are going to spend way more time tracking this problem down. –  Bailey S Oct 30 '12 at 21:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.