Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've looked all over the web and I can't find an answer to my problem. A few days ago when I would insert a CD, it would auto mount, but now for some reason it isn't showing up.

I was using Ubuntu 12.04 when this started happening, then I re-installed 11.10 thinking that would fix it, but it didn't.

I'm pretty sure the drive is being recognized when the computer starts up, but I'm not positive. Any help would be greatly appreciated. If you need any outputs from commands just let me know.

share|improve this question
Does the drive work? – Dr_Bunsen Oct 30 '12 at 18:16
no when i insert a cd or dvd nothing shows up. im wondering if i have a hardware problem and not a software issue – Spencer Oct 30 '12 at 18:18
unless by "work" you mean does it eject and take in cd's, then yes it works – Spencer Oct 30 '12 at 18:23
I meant, does it work outside Ubuntu?! just load a disc in it and (for example a live disk) and if it loads, it's good(means hardware works) and else, well too bad. – Dr_Bunsen Oct 30 '12 at 18:28
it still doesn't work, so i guess it is the hardware. thanks for the help – Spencer Oct 30 '12 at 18:31

See your BIOS setting and check that if your drive still activated. open a terminal and type sudo lshw, this will list your hardware connected

as and example:

                description: DVD writer
                product: DVD RW DW-Q120A
                vendor: SONY
                physical id: 0.0.0
                bus info: scsi@4:0.0.0
                logical name: /dev/cdrom
                logical name: /dev/cdrw
                logical name: /dev/dvd
                logical name: /dev/dvdrw
                logical name: /dev/sr0
                version: PYS3
                capabilities: removable audio cd-r cd-rw dvd dvd-r
                configuration: ansiversion=5 status=nodisc
share|improve this answer
there isnt an option to enable or disable the drive – Spencer Oct 30 '12 at 19:23
Check your BIOS documentation – DebojyotiMukh Nov 3 '12 at 11:34

I had the same problem... It's not problem with driver. Just take some lens cleaner and clean lens. After that CD/DVD should work just fine. Cheers =)

share|improve this answer

*-cdrom description: DVD-RAM writer product: DEVICE 81Y3670 vendor: IBM SATA physical id: 0.0.0 bus info: scsi@2:0.0.0 logical name: /dev/cdrom logical name: /dev/cdrw logical name: /dev/dvd logical name: /dev/dvdrw logical name: /dev/sr0 version: IB01 capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram configuration: ansiversion=5 status=nodisc I am having issues in reading CDs written on my other systems only (Medical Machines like Echocardiography or Cardiac catheterization Lab), while rest all CDs are read by UBUNTU 15.10. The same CDs are read in Windows7. Please help, I have done "sudo apt-get install libdvd-pkg" thinking some restriction in CDs written by Medical system computers.

It is affecting my work adversely, please suggest a remedy.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.