Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I been using a test Xubuntu 12.04 LTS on my 64 bit workstation, because Ubuntu has dropped support for the nvidia graphic adapters my 10.04 LTS and I haven't been able to get them working.

Now update manager has upgraded the kernel from 3.2.0-30-generic to 3.2.0-31-generic, and failed to produce a working nvidia module that the X server can load.

Fortunately, when launching the 3.2.0-30-generic kernel, I still have use of the X server.

Does anybody know a work-around or fix for this?

I'm really worried, this is the last working Ubuntu distribution OS on the computer and I don't want to give up on Ubuntu.

Details of problem here.

The system (hardware) successfully boots ArcLinux x86_64, Vista Ult 64, Windows XP x64. Before problems with nvidia graphic adapters, the system boot successfully Ubuntu 10.04 LTS.

The output of lspci -v is here.

share|improve this question

closed as too localized by fossfreedom May 22 '13 at 22:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
If all else fails, you may want to download and install directly from NVIDIA (askubuntu.com/questions/203497/…). You will need the kernel headers for successfully building the kernel module during installation. Good luck. –  cogitoergosum Oct 30 '12 at 17:31
    
The answer was to wait until a later update from Ubuntu so it worked. BTW, the same thing happened again. Not as much fun as playing slots.... –  keepitsimpleengineer Dec 22 '12 at 18:42

1 Answer 1

There is an issue with ubuntu 12.04 where some nVidia cards do not work with the nVidia drivers that are in the standard repository. As well, these cards will not boot the gui property.

I don't know if the same problem exists on Xubuntu, since I don't use it, but on the offchance that this is what is affecting you, then the information contained here https://wiki.ubuntu.com/fballem/Software%2012.04 may prove helpful.

I hope that this helps,

share|improve this answer
2  
Thanks for the suggestion. The nvidia driver for the 3.2.0-30-generic kernel which works is the same one for the 3.2.0-31-generic which does not work. The problem as reported by Xorg.0.log is that the nvidia module could not be found for the 3.2.0-31-generic kernel. Why it finds it for the 3.2.0-30-generic and not the 3.2.0-31-generic kernel is inexplicable. :¬( –  keepitsimpleengineer Nov 3 '12 at 19:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.