Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using Von Welch's instructions to install a 500 GB Seagate drive to write the recordings to.

Everything seemed to be going okay until mkfs /dev/sdb1 then we get an error message:

mkfs.ext2: inode_size (128) * inodes_count (0) too big for a
filesystem with 0 blocks, specify a higher inode_ratio (-i)
or lower inode count (-N)

My son is trying to help me but this is beyond him. Our knowledge of UNIX/Linux is very limited. At work the support people just sent me a line by line cook book.

The computer is a Gateway MDP e4000 with Mythbuntu installed on a PATA drive and we are adding a SATA drive for the second drive. The BIOS sees the drive.

I would appreciate any help you can give us.

share|improve this question
add comment

2 Answers 2

I'm not suggesting that your disk is physically broken but you should definitely confirm that it isn't. Open a terminal and run:

sudo apt-get install smartmontools
sudo smartctl -d ata -a /dev/sdb

This will show you a table with a header (ID# ATTRIBUTE_NAME FLAG, etc.). Find a line with Reallocated_Sector_Ct and make sure that the number under the column RAW_VALUE is 0. If it isn't, that means that the drive is failing and it's time to replace it.

Then create a single partition (if that's what you want) using fdisk, cfdisk and then create the filesystem on it:

sudo mkfs.ext4 -L 500GB /dev/sdb1
share|improve this answer
add comment

Just use Disk Utility or Gparted to format the hard drive as ext4. If that fails, delete the partitions and the partition tables on the hard drive and start from scratch with Gparted.

After that, all you have to do is put an entry in /etc/fstab so that the drive automounts at boot.

It seems that you've made things way more complicated than they need to be.

share|improve this answer
    
thank you. i will go down and try this. –  dennis ditch Oct 30 '12 at 21:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.