Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a pluscom pci card plugged into my desktop and although the mac address shows up in network manager, it says "Wireless unavailable".

I'm using Ubuntu 12.10 Gnome Shell Remix...

edgar@edgarQuantal:~$ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

edgar@edgarQuantal:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 6c:f0:49:02:1f:b8  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::6ef0:49ff:fe02:1fb8/64 Scope:Link
          RX packets:1425 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1393 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:995753 (995.7 KB)  TX bytes:134079 (134.0 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:363 errors:0 dropped:0 overruns:0 frame:0
          TX packets:363 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:40828 (40.8 KB)  TX bytes:40828 (40.8 KB)

It looks the same as the problem as here, seems quite complicated:

Tried downloading the driver but i get this:

"Unpacking firmware-ralink (from .../firmware-ralink_0.36_all.deb) ... dpkg: error processing /home/edgar/Downloads/firmware-ralink_0.36_all.deb (--install): trying to overwrite '/lib/firmware/rt2870.bin', which is also in package linux-firmware 1.95"

share|improve this question
Are you running 32- or 64-bit Ubuntu? – belacqua Nov 1 '12 at 15:31

An interface should always have a MAC address associated with it. If it says "wireless unavailable" I would expect that you are not seeing or associating with an access point or wireless switch/router.

Does your wireless work from a different OS, a different device, or from your system running from a LiveCD/DVD?

For general troubleshooting, see this page.

See Broadcom 4312 wireless issues and How can I troubleshoot my installation of the latest Broadcom driver?

Also try resetting power (via this answer ) :

Remove all power sources(cables/batteries).
Act like you're powering on the device (press and hold the power button or power cycle several times even though it has no power).
Reconnect all power sources and boot.

The goal of that set is to remove power from wherever the wireless card stores the hardware disabled state and defaults to 'enabled' on the next boot.

Based on the forum thread you mention, you might try this driver: .

share|improve this answer
I presumed that because network manager sees that the card exists that it should work. Instead it says its disabled and therefore I can't even scan to see SSIDs never mind connecting. The card is enabled both physically and through the software as shown in the terminal. I have tried installing the broadcom drivers from the software centre but these make no difference. – Luigi Oct 30 '12 at 16:35
Can you see SSIDs with any other devices? Can you add the ifconfig output (obfuscating as necessary) as an edit to your original? – belacqua Oct 30 '12 at 18:00
On the gnome shell remix live cd it says the device is not ready, can see the ssid on my laptop which I'm using right now. – Luigi Oct 30 '12 at 21:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.