Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 12.10 desktop 64-bit. I've installed the latest version of XBMC (Eden). Everything seems to be working great.

The only small issue I'm running into is that I can't figure out how to make XBMC launch automatically on boot/restart. In the 'Startup Applications Preferences' dialog in Ubuntu I have added a new launcher with the command

/usr/bin/xbmc

and ticked the checkbox next to it. When I restart though XBMC doesn't launch. I know this is the correct path because I ran

which xbmc

in the Terminal to confirm it.

Am I doing something really stupid here? How come XBMC won't launch automatically? It works fine if I click its icon in the dock.

Many thanks,

share|improve this question
1  
Why not just use the auto login feature and choose the XBMC session created when you install it? –  Bruno Pereira Oct 30 '12 at 14:52
    
I don't understand what you mean by this (sorry - new to Linux) –  Garry Oct 30 '12 at 15:18
    
@BrunoPereira I did the method you mentioned but I think my xbmc session does not have permission rights. I can't open the existing files. But It works fine when just using the auto start application feature of Ubuntu –  Gary Lising Aug 15 '13 at 17:30
    
Then you need to adjust your permissions on your files, I would say... –  Bruno Pereira Aug 16 '13 at 8:33
add comment

3 Answers

up vote 5 down vote accepted

Run:

gedit ~/.config/autostart/xbmc.desktop

write in file

[Desktop Entry]
Type=Application
Exec=xbmc -d 5 --standalone -fs
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[en_En]=xbmc
Name=xbmc
Comment[en_En]=
Comment=

save file and restart system.

XBMC will start with five second delay, in standalone mode and full screen mode.

share|improve this answer
    
'gedit' would automatically create the file, so the 'touch' command is not necessary (especially since it had a typo). I removed it. –  ImaginaryRobots Jan 25 '13 at 23:22
    
Thank you. That worked! –  Garry Jan 26 '13 at 8:01
    
Thanks, worked for me too. On question though: the file disappeared from .config/autostart directory... Is this normal? –  Tinellus Oct 30 '13 at 8:32
add comment

I had a small issue getting it to run automatically too, doing the same thing. My issue was that it would not start full screen, even when passing it the -fs argument. As Bruno Pereira has suggested, using the XBMC session works great. Click the little Ubuntu symbol next to your username when you log in and select XBMC. If you have set your computer to auto-login, you will have to log out to do this. Then when you want to do something on your computer not XBMC related, simply log off, and log back in, changing the session back to Ubuntu.

The other option, which may work for you is to create a small script like this:

#!/bin/bash
/bin/sleep 5
/usr/bin/xbmc -fs

Save this somewhere as xbmcstartscript.sh, then use

chmod +x xbmcstartscript.sh

to make it executable. Now use that script for your startup application, instead of pointing directly to XBMC.

Apparently there is some sort of conflict/race condition where XBMC will try to start up before Unity is done loading, so you need to wait a few seconds before opening XBMC.

share|improve this answer
    
The script didn't work for me. I'll try the session option this evening when I get home. Will I be able to VNC the login screen once I log out (that's how I control the PC)? –  Garry Oct 31 '12 at 8:23
    
I don't use VNC anymore but if I recall correctly, by default, VNC only runs when logged in. This may help to run it as a daemon, so you can still connect to it while at the login screen, askubuntu.com/questions/83824/…. –  reverendj1 Oct 31 '12 at 14:05
add comment

A better option is to make XBMC your session. You won't get into unity etc, so it's all a bit cleaner.

  1. if you auto-log in, then logout of your current session.
  2. on the log-in screen, press the ubuntu logo next to your name
  3. choose 'XBMC'
  4. log in.

This makes XBMC go all fullscreen when you (auto?) log in.

share|improve this answer
    
hmm. I missed the short intro reverendj1 wrote about this, so maybe superfluous, but wrote it as an explanation of the comment on the question :) –  Nanne Jan 26 '13 at 9:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.