Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to play XCOM on Wine (using Play on Linux). Unfortunately, this doesn't work.

The debug option in POL outputs this:

Running wine-1.5.15 play-XCOM.exe (Working directory : /home/stephen/.PlayOnLinux/wineprefix/XCOM/drive_c/XCom Enemy Unknown)
p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directoryfixme:shell:SHAutoComplete stub
fixme:exec:SHELL_execute flags ignored: 0x00000180
err:module:import_dll Loading library X3DAudio1_7.dll (which is needed by L"C:\\XCom Enemy Unknown\\Binaries\\Win32\\XComGame.exe") failed (error c000007b).
err:module:import_dll Loading library XAPOFX1_5.dll (which is needed by L"C:\\XCom Enemy Unknown\\Binaries\\Win32\\XComGame.exe") failed (error c000007b).
err:module:LdrInitializeThunk Main exe initialization for L"C:\\XCom Enemy Unknown\\Binaries\\Win32\\XComGame.exe" failed, status c0000135

This leads me to believe that Wine is missing X3DAudio1_7.dll and XAPOFX1_5.dll. I transfered these files from my Windows install into

/home/stephen/.PlayOnLinux/wineprefix/XCOM/drive_c/windows/system32

but it still gives me the same error. What can I do? I tried using Wine overrides but that didn't seem to help either.

I'm running Xubuntu 12.04, XCOM is running in wine 1.5.15

share|improve this question
add comment

2 Answers 2

I've fixed the error by installing the dxfullsetup and d3dx11 packages.

share|improve this answer
add comment

download this X3daudio1_7.dll file again Re-Register the DLL File Disable Audio Acceleration

here are manual instructions

http://www.pcfresher.com/x3daudio1-7-dll-not-found-or-missing-errors-in-monaco.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.