Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

(Before anyone asks -- I've installed the Guest Additions correctly. :] ) When I turn on on Seamless Mode for VirtualBox, it seems to work, but my windows no longer have any borders, and so I can't move them, maximize them, etc.

Why is this? Is there a fix?

share|improve this question
    
Do you have compositing on or off? Are 2D/3D support for the virtual machine turned on? Is there any other relevant graphics information you'd like to give us? –  jrc03c Jan 12 '11 at 5:30
    
Everything is fine, I get all the effects and such, no other problems; acceleration is all to the max, and I have an NVIDIA GeForce GT 330M GPU. It's not a graphics issue, but either a VirtualBox issue or an Ubuntu issue. –  Mehrdad Jan 12 '11 at 5:33

1 Answer 1

up vote 5 down vote accepted

Seemless mode will not work with compositing on. Whatever method they use to detect the windows can't recognize the borders. Turn off Visual Effects and you'll have borders again.

Here is the bug report if you want to track it: http://www.virtualbox.org/ticket/6167

share|improve this answer
    
It won't let me vote up PKKid's answer, but that was perfect. Using Ubuntu 10.04 I went to System > Preferences > Appearance > Visual Effects. By default it was set to "Normal", so I set it to "None". Worked a treat - I now have window borders in VirtualBox seamless mode (Win7 host), thank you!! –  Aaron Oct 18 '11 at 14:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.