Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.10 on my Lenovo W500 and this annoying popup keeps appearing on start up.

enter image description here

The text sais: "SIM PIN unlock required" and "The mobile broadband device 'Ericsson F3507g' requires a SIM PIN code before it can be used." (for search engines)

I do not plan on using this device and I just want to disable this popup.

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Is the Mobile Broadband card removable, i.e. just a card? You could just pull it out then. Also, if you fire up Network Manager (Network Connection), and click the "Mobile Broadband" tab, you should be able to either Edit it, and tell it to never connect, or delete the connection altogether. Sorry, I do not have a mobile broadband card, so I cannot give more detail.

share|improve this answer

Tick mark on option Automatically unlock this device. You can disable it permenantly from making PIN disable. You can ask your provider to remove Pin of sim.

share|improve this answer
1  
I do not know my PIN, as I have never used this card before. –  ayckoster Oct 30 '12 at 14:43
    
When I tick "Automatically unlock this device" and successfully enter the PIN code, I still get the same prompt once in a while. I wonder why it fails to remember this? –  Sadi Apr 22 at 15:17
    
Doing this will remember the pin for as long as the device is powered. As soon as you restart or put your laptop to sleep, it'll ask again. So this is quite useless, I'm not even sure what's the difference with this unchecked. –  BigBourin yesterday

You have to know the PIN of the SIM if you want to disable PIN checking. There are two possibilities:

1) Put the SIM card into your mobile phone, enter the pin. Look for "disable PIN" in the settings of your mobile phone.

2) Use gsmctl as described here:

sudo apt-get install gsm-utils
sudo gsmctl -d /dev/ttyUSB0 -o unlock sc all 1234

where 1234 is the PIN. Check for the device path (ttyUSB*) with dmesg after plugging in the GSM modem. It should look similar to this:

[13274.395894] option 2-4:1.0: GSM modem (1-port) converter detected
[13274.396084] usb 2-4: GSM modem (1-port) converter now attached to ttyUSB0
share|improve this answer
    
Actually it is not a real answer. Because the user don't know him PIN number, so your method will never work for him. Also, the above answer will do the same as your information an more easy –  Lucio Jan 18 '13 at 20:43
    
I have a built-in SIM, how can I find its device name please? –  Sadi Apr 22 at 15:35
    
@Sadi What do you mean by device name? If you are looking for the device in /dev/ you can try hwinfo –  herr-biber Apr 25 at 20:38
1  
I mean device path. As I don't have a USB GSM modem, but a SIM card inserted into a slot, I think it should be something different than "/dev/ttyUSB0". How do I know that? –  Sadi Apr 25 at 20:46
    
Have you checked hwinfo and dmesg for tokens like gsm or modem? –  herr-biber Apr 25 at 22:35

Since you don't want to use your inbuilt 3G-modem you can disable it device:

Open in command-line sudoedit /etc/rc.local and before the line with exit 0 add:

rfkill block wwan
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.