Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Conky can't get my wireless essid due to the wl kernel module and neither could my normal user account. If I did sudo iwconfig wlan0 it was fine, and if I ran conky as root it was fine, but I don't want to do that.

The solution was the here more specifically this link is what I followed, and it worked great. For awhile.. Now it doesn't work anymore and I'm not sure why.

It worked for my user acount. If I run iwconfig I see all the wireless info. If I enter ${exec iwconfig wlan0} in my conky config conky spits out all the wireless info, including ssid. But using conky's built in ${wireless_essid wlan0} returns nothing for ESSID and 'Not-Associated' for the AP MAC.

I've tried all I can, including sudo chmod u+s /sbin/iwconfig (which also worked before, but now fails to work for conky)

I should also clarify that I edited the udev rule to rename eth1 to wlan0, as eth1 is the standard interface name that comes up with the wl driver.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Alright, so the solution for anyone else that ends up here:

sudo setcap cap_net_raw,cap_net_admin=eip /usr/bin/conky

Details are here but basically you need to give conky permissions to use the network interface.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.