Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu with latest KDE on a Lenovo Z570 with Optimus.

I've installed drivers and bumblebee, both integrated and nVidia cards are working perfect (not the issue).

I have a RAT 9 Wirless mouse, which I tried to configure and this is the problem.

I needed to edit Xorg.conf in order to make it work. But apparently I did not have any file Xorg.conf in either /etc/X11 or /usr/share/X11. By the way, Xorg.conf or Xorg.conf.d? I've looked for both but I've found none.

So I created the folder Xorg.conf.d in /etc/X11/Xorg.conf.d/ and created the file 910-rat.conf, where I created the Section "InputClass" with the Identifier, Product, Button Mapping and everything. Saved, rebooted, got stuck.

Normal Boot:

After the boot logo (5 charging dots) I get the Black Screen. I tried Ctrl+Alt+F1, Ctrl+F1, Ctrl+Alt+F5, I've tried editing the startup parameters in Grub, with nomodeset instead of quiet splash, and the init=/bin/bash trick ... but to no avail.

Recovery mode:

Stuck at:

[2.315147] Freeing unused kernel memory
Loading, please wait...
[2.32...] udevd[108]:starting version 175
[2.35...] r8169 Gigabit Ethernet ...
...(some more pci and eth0)
[2.359..] [drm] Initialized drm 1.1.0 20060810
[2.36...] pci ... PCI INT A -> GSI 16(level, low) ->IRQ 16
[2.370..] fb: conflicting fb hw usage inteldrmfb vs EFO VGA - removing generic driver

and that's it...

I just found out drivers from nVidia are not recommended, I don't remember if I installed from nvidia or xswap...something repo, or both. But what do I do now? I would prefer not to reinstall Ubuntu, as my KDE setting took me like a week to set, and I don't know where they are stored, as I don't have a Xorg.conf file. Why don't I have it?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.