Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had created a demo web application by executing rails tickets and then i executed rails script/server to run it on localhost.

Initially i was able to execute the application in the browser by typing localhost:3000 in the address bar, but then I deleted the folder tickets from my hard disk.

Now again i created the same folder but when i try to run it using the same command rails script/server it says that

vverma@l-vverma:~/railsExp/tickets$ rails script/server 
      create  
File exists - script/server

I tried deleting the script/server file but i still couldn't run the localhost:3000 in the browser

Tried rails s as well, it gave the following output:- http://paste.ubuntu.com/1317610/

But still i was unable to run the app on 'localhost:3000'

What is the solution to this

share|improve this question
1  
Looks like you're running rails 2.x - you might want to use rails 3.0 instead, it's got better support/documentation. –  jrg Oct 30 '12 at 14:34
    
do i have to run this script/server command everytime i make any change in the code? –  vipin8169 Oct 31 '12 at 9:00
1  
I don't know about rails 2.x, but in 3.x you don't need to. –  jrg Oct 31 '12 at 12:16

1 Answer 1

up vote 0 down vote accepted

Command to start it is ruby script/server and not rails script/server that is the solution :P

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.