Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a lampp webserver and i need to edit animated gif files. I have tried to install imagick with this tutorial. But at the "make" commad i get the error

can't read /usr/lib/x86_64-linux-gnu/libjpeg.la: No such file or directory

i already managed to install the 32bit version, but the server gives me an error:

Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20090626/imagick.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20090626/imagick.so: wrong ELF class: ELFCLASS64 in Unknown on line 0

I googeld the error and someone said, that the server want a 64bit version of the file...

I'm new to compiling files and never installed addons on my webserver... If you need aditional informations, logs or some file, please tell me

(Sorry for my bad english :D)

share|improve this question

1 Answer 1

It is now bit too late, but here I come with the proper solution to install iMagick with LAMP or XAMPP Server on Linux based systems. It is only the iMagick extension of PECL that works with PHP. So you don't have to worry for Image Magick and Magick Wand to install.

First of all remove everything you have tried to make it work. Uninstall ImageMagick with the following command:

sudo apt-get remove imagemagick

Remove ImageMagick and all its dependencies with the following command:

sudo apt-get remove --auto-remove imagemagick

Purge the config file of ImageMagick with the following command:

sudo apt-get purge imagemagick

Or similarly, like this:

sudo apt-get purge --auto-remove imagemagick

Well, all your previous installation files are just gone. Now Install it purely and perfectly without any conflict or file modification. Enter the following two commands:

sudo apt-get install imagemagick
sudo apt-get install php5-imagick

That was way too easy - thanks interwebs! Remember to restart/reload your webserver..

sudo service apache2 graceful

That's all. Check your php.ini or test with any simple script.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.