Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When Ubuntu starts, the Unity toolbar is displayed at the background and all windows are displayed above it. When I hit the Super button on my keyboard, the Dash opens but remains at the background so it's unusable. I found out that closing my session and re-opening a session fixes the problem. Does anyone have a better solution ? Seems like Unity/Compiz are starting on the wrong order.

share|improve this question
add comment

2 Answers

First you need to install myunity. this is how:

  • open terminal

type in, sudo add-apt-repository ppa:myunity/ppa

type in, sudo apt-get update

type in, sudo apt-get install myunity

Then that is done, open up the dash and type myunity.

And it should come up as this, enter image description here

Then click the arrow that is Behavior, enter image description here

And click fixed. That is all, tell me if you have problems.

share|improve this answer
    
Thanks for your answer but I cannot try this solution since MyUnity doesn't exist for Ubuntu 12.10 ... I'll try to find another app that allows to make the same configuration tweak (maybe Ubuntu Tweak ?) –  Cowboydan Nov 15 '12 at 10:24
add comment

Take a look here. To be short: you need to disable and re-enable unity plugin in compiz settings manager. Al least it helped me (I'm using ATI opensource drivers).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.