Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Sony Vaio laptop which has a BIOS enabled motherboard. I recently bought an SSD. I was using Arch and Ubuntu with Windows 7 on my 320GB HDD before that and would prefer doing the same after installing the new SSD.

I wanted to use GUID partition table (GPT) on my SSD for the reason that it supports more than just 4 partitions. (I was thinking may be I can install later some other OSes as well).

I went through the guide of Rodsbooks. So, I made some partitions and these are reflected as

sudo gdisk /dev/sda
GPT fdisk (gdisk) version 0.8.1

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.

Command (? for help): p
Disk /dev/sda: 500118192 sectors, 238.5 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): 2C8E0936-465F-4BE2-B8D5-CA10A0C408C4
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 500118158
Partitions will be aligned on 1-sector boundaries
Total free space is 2014 sectors (1007.0 KiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048         1075199   524.0 MiB   EF00  
   2         1075200         1077247   1024.0 KiB  EF02  
   3         1077248         1339391   128.0 MiB   0C01  
   4         1339392       127168511   60.0 GiB    0700  
   5       127168512       169111551   20.0 GiB    8300  
   6       169111552       211054591   20.0 GiB    8300  
   7       211054592       251054592   19.1 GiB    0700  
   8       251054593       500118158   118.8 GiB   0700 

Till here, I was happy with Windows 7 x64 installation. Then I proceeded to install Arch x64 and Ubuntu 12.04 x64 (which I later upgraded to 12.10). Ubuntu installed grub and now I cannot boot to Windows any more. Moreover, it also does not recognize the Arch Linux partition either, which I think I installed successfully.

I tried the solution by jarondl in here but not to much help.


  • How I can I direct my Ubuntu (and/or Arch) to install kernels on /dev/sda1?

  • Can I install rEFInd on my system?

  • Can I upgrade my Windows 7 to Windows 8 or do a fresh install of Windows 8, will that create a problem?

share|improve this question
Please indicate your Boot-Info URL – LovinBuntu Oct 31 '12 at 9:11
Here it is link – Pankaj Parag Nov 4 '12 at 4:54
Reinstalling UEFI DUET restored UEFI Boot screen. – Pankaj Parag Nov 13 '12 at 7:29

First, it's not clear if the Ubuntu-installed GRUB is the BIOS-mode version or the EFI-mode version. If the former, you should be able to reconfigure it to launch DUET as well as Ubuntu, which should restore everything else to bootability. To do this, you'll need to edit /etc/grub.d/40_custom to add a boot entry for DUET. Alternatively, you could restore SYSLINUX and then later get your Ubuntu installation booting in EFI mode by replacing the BIOS-mode GRUB with another EFI-mode boot loader. If Ubuntu installed an EFI-mode GRUB, you'll need to either reconfigure GRUB to detect and boot your other OSes or supplement or replace it with something else. My EFI Boot Loaders for Linux Web page describes some of your options.

You can tell which version of GRUB you've installed by checking whether you've installed the grub-pc or grub-efi package in Ubuntu; the former is the BIOS-mode package and the latter is an EFI-mode meta-package (it actually installs an architecture-specific package).

If you find that you're using the EFI-mode GRUB, then installing rEFInd should be pretty easy -- you'll just need to install it using the instructions on the rEFInd Web site. Under DUET, you're likely to have to name it EFI/BOOT/bootx64.efi on the ESP, since DUET seems to forget the changes created by efibootmgr, in my experience. FWIW, my own BIOS-based laptop is booting Windows 7, Fedora 17, and Mint via DUET and rEFInd. (That said, I maintain rEFInd and I'm the author of the Web page on DUET you referenced, so I'm not exactly a novice at this game.)

share|improve this answer
I installed Ubuntu in it's default mode, so I guess it was BIOS mode. I edited /etc/grub.d/40_custom according to the fs_uuid answer mentioned in… and when I tried to boot from that I get some error. I tried to edit that section and boot but doesn't help. I used set=root UUID and which was right from my knowledge. So I removed grub-pc and installed grub-efi and installed refit but nothing happens. I would update tonight after trying rEFInd (it is not in Ubuntu's repo). – Pankaj Parag Oct 31 '12 at 17:25
I'm afraid your description of what you've tried is very imprecise. Without knowing precisely how you edited /etc/grub.d/40_custom, what errors you got when you tried that entry, or precisely what you mean by "nothing happens" with your rEFIt installation, it's impossible to provide more advice. – Rod Smith Oct 31 '12 at 23:13
Pardon for being naive and vague answers and also for being late to reply. So, I checked that my /dev/sda1 partition is still intact with EFI modules on it. But GRUB2 fails to recognize it and so when I installed rEFit, nothing happens means I do not get any pretty menu but am taken directly to GRUB menu. There I edited /etc/grub.d/40_custom by adding search --fs-uuid --no-floppy --set=root 0ED6-CAA5 chainloader (${root})/EFI/Microsoft/Boot/bootmgfw.efi and I get invalid signatures error. Please let me know if you need more information from my side. – Pankaj Parag Nov 3 '12 at 6:56
I tried boot-repair and it created a link Boot-repair Info – Pankaj Parag Nov 3 '12 at 7:25

According to your last Boot-Info ( ):

  1. sda1 is an ESP (EFI partition), so you cannot install any kernel in it.
  2. you have already installed Refind.
  3. if Microsoft did its job well, upgrading Windows7 to Windows8 should not be a problem. But you should backup you documents before such operation.
share|improve this answer
Reinstalling UEFI DUET solved the problem. – Pankaj Parag Nov 13 '12 at 7:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.