Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install 12.04LTS on a server but keep running into the unable to install grub error like so "Unable to Install GRUB in /dev/sda". The drives are in raid1 and I'm using fakeraid on a supermicro motherboard, which according to the manual is fully supported. I've tried installing both from USB and CD-R but still no luck. I'm not dual booting with any other OS, just using 2x320gb drives and have been choosing to install using the entire disk.

Any ideas what I'm doing wrong or can do to fix this? Thanks

share|improve this question
up vote 1 down vote accepted

As I seem you should have used guided partition skim, when you are going to install grub it doesn't see that, so you should make a small (1MB) partition on each disk and RAID them together and set it as a GRUB boot partition. Set up your other RAID partitions (e.g. swap and /) and then the GRUB installer should find the boot area just fine.

share|improve this answer
Sorry I should have clarified exactly what I'm doing. At the moment I'm creating the raid1 array through the onboard intel raid controller utility, rather than through ubuntu software raid. If I create small partitions on each disk and then raid them, then I lose the partitions once the array has been built. Are you saying that I should stop using the onboard to create the initial raid1 array and just use ubuntu software raid instead? – Henry Oct 30 '12 at 5:33
You can still cahange that, But keep backup of all data. – K.K Patel Oct 30 '12 at 5:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.