Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

About every 3 days on my desktop (always on), X crashes, gdm restarts and it dumps me at a login screen. When I log in Gnome appears to have lost a lot of its settings: it plays sounds in weird places, UI elements look like they're from the 90s (GTK+ defaults) and it's generally pretty hideous.

Note everything works fine. It's not like my profile doesn't exist because I can browse the internet fine (Firefox knows my bookmarks, history, passwords, etc) and my desktop is unscathed (apart from the icon theme).

Manually restarting gdm doesn't fix this. I have to do a full reboot.

Now I'm almost certain that this is a nvidia issue causing X to baulk (I've seen similarish threads on nvnews) and I'm happy with that (my fault for running their latest drivers all the time). What I'm concerned about is why Gnome looks so fugly. Is there anything I can do to force it to reload its settings without restarting the whole computer.

Restarting is an issue for me as I run several daemons that other computers on the network depend upon.

This is what I mean by ugly/fugly... Look at that scroll bar!

Example

share|improve this question
    
ACK, this is somehow related to NVidia. Also older drivers are affected to occasionally loose the theme by loading default GNOME. I also have no pattern on this. –  Takkat Jan 10 '11 at 15:04
    
It seems like something is gumming up gnome-settings-daemon. I only really care about the initial crash and t –  Oli Jan 10 '11 at 15:06
    
Duplicate of askubuntu.com/questions/11406/… . –  João Pinto Jan 10 '11 at 16:33
add comment

1 Answer

up vote 4 down vote accepted

It's a pretty simple deal. Run killall gnome-settings-daemon in a terminal (just to be sure it's really dead), then run gnome-settings-daemon & (or install grun and use grun gnome-settings-daemon).

This will cause gnome to regain it's settings unless you have a more serious issue.

share|improve this answer
1  
Yeah that worked (after I restarted gdm) –  Oli Jan 10 '11 at 14:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.