Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 10.10 to my Lenovo s10-3 a couple of weeks ago. At first there was no problem but yesterday when I tried to connect to internet, I realized that my "wireless" seemed as disabled. I googled about this issue and tried some codes however nothing changed.

I need some help.

By the way, I have no wired connection.

share|improve this question
    
Are you saying that when you right click on the network icon in your panel that you are unable to connect? I always have wireless disabled every time I reboot but am able to right click and enable wireless. I just never can do that and connect after coming back from the computer being in sleep mode then waking. –  user11253 Feb 22 '11 at 3:33
1  
When I right click on the network icon, it is impossible to select wireless networks. And I wonder why there is no update on this issue. Now I can connect to internet just in my office by a network cable and outside I haven't been able to use internet for 2 months. Help please. –  user11962 Mar 7 '11 at 10:36
    
You're not alone, I'm fighting the same issue. Ideapad S10-3 claims the wireless is working fine, but it refuses to see any networks. –  Brian Knoblauch Aug 23 '13 at 10:55
add comment

5 Answers 5

Possible answer for this you should open and reset your laptop Lenovo 10-3 CMOS battery.

share|improve this answer
1  
This right here is the correct answer! –  Brian Knoblauch Aug 23 '13 at 11:55
add comment

There are very few things that would make your wireless not connect (if you haven't updated your software of settings.)

  • Make sure your physical wireless switch is still on. I have knocked into this switch on my Lenovo by mistake several times. It's not terribly obvious when it happens and it's a pain to discover.
  • You could try an external wireless adapter to see if you can get it to work (USB-based.) If yes, then your wireless card may be on the fritz.
  • Check your router to make sure that the computer's IP didn't get blacklisted/firewalled.
  • Also, have you tried wired. Why do you not have one?
share|improve this answer
add comment

I had the same problem on my Lenovo IdeaPad S10-3s. I connected to the Internet via Ethernet and was prompted to download an updated Broadcomm driver. After that, my wireless worked.

share|improve this answer
    
Broadcomm driver does not work on my S10-3. Mine appears to require the Atheros driver. Must be a lot of versions of the S10-3 as I see Lenovo has 3 different brands of wifi drivers available! –  Brian Knoblauch Aug 23 '13 at 10:56
add comment

The likelihood is the wifi driver is a proprietary driver.

Unfortunately, you will need to get to the Internet somehow to get the proprietary drivers for your specific system.

share|improve this answer
add comment

I have a Lenovo Z750 laptop and I had recurring wireless problems in ubuntu and windows, notably the wireless would hang and then appear to be disabled by hardware switch. My method to fix the problem was restart the laptop and set the wireless settings back to factory settings, this was a pain and made using the internet impracticable.

I tried many different drivers, you must make sure that you only have one driver installed. Sometimes there are a number of drivers which would work for your wireless card. Type:

lspci -k
.....
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
Subsystem: Broadcom Corporation Device 051b
Kernel driver in use: wl
Kernel modules: wl, bcma, brcmsmac
.....

Find the network controller, perhaps purge drivers you don't want!

This didn't work for me, so I tried a friends wireless usb stick because I was getting mad.

At the same time I swapped wireless cards with another laptop Dell mini 10v, my wireless card worked fine in the other laptop so I was happy that it worked. When I put the wireless card back into the original laptop Z570, I have never had a problem since.

Check the warranty though should be fine, was for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.