Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 10.10 on my MacBook Air 11" (late 2010 model 3,1). Compiz runs fine, as well as most of GNOME Shell's animations.

The animation for switching to and from GNOME Shell overview is just very slow. Unfortunately, it's the most common animation on Shell.

I already applied

cd ~/gnome-shell/source/gnome-shell
curl http://bugzilla-attachments.gnome.org/attachment.cgi?id=157326 > shell-animations-nvidia.patch
git am shell-animations-nvidia.pat

that I found from http://live.gnome.org/GnomeShell/SwatList , but the issue's still here.

How do I fix this?

EDIT:
Apparently, it's an NVIDIA driver bug, which has something to do with the message tray. Is this correct? How do I go around this issue?

share|improve this question
    
This question seems abandoned, there is not further information or activity added to it for several months. I am flagging this to be closed by a moderator. If you think this issue is still affecting you you can flag a moderator to re-open it. –  Bruno Pereira Feb 3 '12 at 1:29
add comment

closed as too localized by Marco Ceppi Feb 3 '12 at 1:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Out of curiosity, are you using the default theme? A lot of custom themes I've tried have had inexplicably low frame-rates during that animation.

share|improve this answer
    
Using the default theme –  AllanCaeg Feb 20 '11 at 8:59
1  
The NVIDIA driver bug is confirmed, btw –  AllanCaeg Feb 20 '11 at 9:00
add comment

After using the Gnome-Shell built from source on 10.10 for about a month, compiling daily, the last few weeks builds have been going from normal to slow on my Nvidia card with the nvidia-current driver.

The experimental driver works great for me on 11.04 ALPHA

share|improve this answer
    
Which experimental driver? Link please :) –  AllanCaeg Feb 23 '11 at 4:56
    
It is the nouveau driver with experimental 3D. In Natty they can be installed under drivers. Might even be default by now nouveau.freedesktop.org/wiki –  Seth Hikari Feb 23 '11 at 19:30
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.