Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Today I installed:

  1. Ubuntu 12.04
  2. Oracle JDK 7 and 8
  3. IntelliJ 11.1.4

I setup my JAVA_HOME path to point to JDK 7.

When I run IntelliJ I get this message:

Gtk-Message: Failed to load module "canberra-gtk-module"

Is this a problem or can I over look this?

share|improve this question
up vote 22 down vote accepted

I fixed this by installing the module:

sudo apt-get install libcanberra-gtk-module

Or if it's already installed and you still get the error:

sudo apt-get install libcanberra-gtk-module:i386
share|improve this answer
I have libcanberra-gtk-module already installed and it is still showing the error. any ideas? – Jim Ford Jun 4 '14 at 15:44
@JimFord See… – belacqua Jul 8 '14 at 15:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.