Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem enabling USB 3.0 on my laptop Some relevant info:

uname -a

Linux HP-ProBook-6570b 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

lspci -nnk

00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller [8086:1e31] (rev 04)
Subsystem: Hewlett-Packard Company Device [103c:17ab]
00:1a.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 [8086:1e2d] (rev 04)
Subsystem: Hewlett-Packard Company Device [103c:17ab]
Kernel driver in use: ehci_hcd
00:1d.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 [8086:1e26] (rev 04)
Subsystem: Hewlett-Packard Company Device [103c:17ab]
Kernel driver in use: ehci_hcd
...

lsusb

Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 138a:003d Validity Sensors, Inc. 
Bus 001 Device 004: ID 0461:4dfe Primax Electronics, Ltd 
Bus 002 Device 003: ID 0a5c:21e1 Broadcom Corp.

dmesg

[    1.152273] usb usb1: >SerialNumber: 0000:00:1a.0
[    1.152342] hub 1-0:1.0: >USB hub found
[    1.152345] hub 1-0:1.0: >2 ports detected
[    1.152396] ehci_hcd 0000:00:1d.0: >setting latency timer to 64
[    1.152399] ehci_hcd 0000:00:1d.0: >EHCI Host Controller
[    1.152402] ehci_hcd 0000:00:1d.0: >new USB bus registered, assigned bus number 2
[    1.152419] ehci_hcd 0000:00:1d.0: >debug port 2
[    1.156304] ehci_hcd 0000:00:1d.0: >cache line size of 64 is not supported
[    1.156307] ehci_hcd 0000:00:1d.0: >irq 16, io mem 0xd4738000
[    1.168203] ehci_hcd 0000:00:1d.0: >USB 2.0 started, EHCI 1.00
[    1.168225] usb usb2: >New USB device found, idVendor=1d6b, idProduct=0002
[    1.168228] usb usb2: >New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.168231] usb usb2: >Product: EHCI Host Controller
[    1.168247] usb usb2: >Manufacturer: Linux 3.5.0-17-generic ehci_hcd
[    1.168248] usb usb2: >SerialNumber: 0000:00:1d.0
[    1.168309] hub 2-0:1.0: >USB hub found
[    1.168311] hub 2-0:1.0: >2 ports detected
[    1.168347] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    1.168356] uhci_hcd: USB Universal Host Controller Interface driver
[    1.168374] xhci_hcd 0000:00:14.0: >can't derive routing for PCI INT A
[    1.168375] xhci_hcd 0000:00:14.0: >PCI INT A: no GSI
[    1.168375] 
[    1.168391] xhci_hcd 0000:00:14.0: >setting latency timer to 64
[    1.168394] xhci_hcd 0000:00:14.0: >xHCI Host Controller
[    1.168397] xhci_hcd 0000:00:14.0: >new USB bus registered, assigned bus number 3
[    1.168479] xhci_hcd 0000:00:14.0: >cache line size of 64 is not supported
[    1.168480] xhci_hcd 0000:00:14.0: >request interrupt 255 failed
[    1.168482] xhci_hcd 0000:00:14.0: >USB bus 3 deregistered
[    1.168493] xhci_hcd 0000:00:14.0: >can't derive routing for PCI INT A
[    1.168495] xhci_hcd 0000:00:14.0: >init 0000:00:14.0 fail, -22
[    1.168498] xhci_hcd: probe of 0000:00:14.0 failed with error -22
[    1.168517] usbcore: registered new interface driver libusual

One more thing this laptop runs in natve UEFI mode Any idea how to solve this problem?

share|improve this question
add comment

4 Answers 4

up vote 1 down vote accepted

The following bit means that it can not allocate a GSI interrupt or a legacy interrupt for the device, which evidently makes it fail. It is probably a kernel bug, relating to the case of UEFI and your USB3 device.

[    1.168374] xhci_hcd 0000:00:14.0: >can't derive routing for PCI INT A
[    1.168375] xhci_hcd 0000:00:14.0: >PCI INT A: no GSI
[    1.168375] 
share|improve this answer
    
Have tested it with mainline kernels in UEFI mode USB 3.0 fails in bios mode USB 3.0 Works reported it in launchpad. –  user102000 Oct 30 '12 at 19:10
    
Can you just use the machine in bios mode instead of UEFI until the problem naturally works its self out? –  Bailey S Oct 30 '12 at 20:33
    
Im dual boting with windows in UEFI so swiching back and forth would be problematic (can't reinstall windows) but i can wait til the problem gets solved –  user102000 Oct 31 '12 at 11:14
    
I suppose there are worse things in the world than not having USB3. Have you tried filing a bug report with Ubuntu, or the kernel team? –  Bailey S Oct 31 '12 at 17:17
add comment

Sorry I was not clear enough.

The message in French and in English is the same :

  • With Ubuntu 12.10/ Linux Mint 14 the usb3 didn’t worked on my ASUS Zenbook Prime UX31A : When I plugged in my hard drive (usb3) on my computer, I couldn’t open the hard drive.
  • The problem comes from the kernel included in ubuntu 12.10/linux mint 14. The basic kernel in Ubuntu 12.10 is the 3.5.0.
  • To correct the problem I installed a newer kernel : I installed the 3.5.7 one and the problem was solved.

To change the kernel, it’s really easy: https://wiki.ubuntu.com/Kernel/MainlineBuilds

The Kernel 3.5.7 for Ubuntu 12.10/Linux mint 14: http://kernel.ubuntu.com/~kernel-ppa/mainline/linux-3.5.y.z-review/current/

Is it more clear now? =$ Really sorry for my English!... I’ll try to be better…

share|improve this answer
    
Please edit and format the original answer, rather than write a new answer with the same information. –  user68186 Dec 10 '12 at 15:51
add comment

Just for information, I had the same problem with my laptop (ASUS Zenbook Prime UX31A). The USB3 didn't work with ubuntu 12.10... I changed my kernel (I have installed the 3.5.7 linux kernel) and the problem was solved. Maybe you should try. Good luck! (Sorry for my english =$... My english is so bad...)

The answer in french----- ça va être un peu plus facile pour moi là!^^ Bon du coup petite info pour tous ceux qui ont miséré pour configurer le usb3 sur ubuntu 12.10/linux mint 14 sur un ASUS Zenbook Prime UX31A : Après avoir tenté pas mal de choses, j'ai opté pour une install d'un kernel plus récent. J'ai installé le 3.5.7 et le pb de l'usb3 était résolu! =D Par contre le pb peut revenir suivant le kernel utilisé : le pb est revenu lorsque j'ai voulu passer sur le 3.6. Par contre là je suis sur le 3.7 et plus de soucis... http://doc.ubuntu-fr.org/kernel Le noyau (3.5.7) sont dispo ici : http://kernel.ubuntu.com/~kernel-ppa/mainline/linux-3.5.y.z-review/2012-11-30-quantal/

share|improve this answer
1  
If someone could translate and edit the post for us the better:D –  smartboyhw Dec 7 '12 at 15:47
add comment

This problem has been fixed with kernel 3.8.5. Download from http://kernel.ubuntu.com/~kernel-ppa/mainline/.

eRiC

https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.8.5: "USB: xhci: correctly enable interrupts"

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.