Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've enabled a bunch of no-prefix shortcuts is tmux (like Alt-c for new window, Alt-n for next), which has made my life so much better. The problem was, my shortcuts didn't always work. Maybe every 5-10 presses, something would just swallow the keypress, and I'd have to do it again. Sometimes it would send input to the terminal, which was even worse.

I worked this out for myself, but I wanted to post it as a question because I couldn't find anything when I was searching. Lots of people talk about the "menu access key" problem, but this is actually unrelated. Edit: Moved my answer out of the question.

share|improve this question
    
You can post a question and this as an answer to your own question. :) –  Evandro Silva Oct 29 '12 at 18:41

1 Answer 1

up vote 0 down vote accepted

The problem turned out to be Unity. The bare Alt key is the default "Key to show the HUD", and somehow that binding was occasionally mucking with Alt chords in my terminal. Here's how to unset it:

# install ccsm if you don't have it
sudo apt-get install compizconfig-settings-manager
# open the compiz settings
ccsm

In the window that comes up, find the "Unity" plugin under the "Desktop" section. The very first item in there is "Key to show the HUD", which defaults to "". Click on the "" button and uncheck the "Enabled" box. Done!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.