Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

At first I was downloading Ubuntu 12.10 using Windows Installer, but I cancelled it after just 2-3 minutes and downloaded 32-Bit ISO (ubuntu-12.10-desktop-i386).

Then I created bootable USB Stick (new HP 210 v210 w) using Pendrivelinux (Universal-USB-Installer-1.9.1.4).

  • I Formatted D Drive. (Both by Windows & EaseUS)
  • I've set boot priority correctly.

But after getting message

"Boot Error":

  • I ran wubi.exe directly from USB drive.

Now the message is

"A previous installation was detected in D:\ubuntu. Please uninstall that before continuing."

  • I formatted D: again and performed disk check, surface test using EaseUS. It shows no error or bad sectors.

  • Formatted & checked my pendrive too.

  • Directly ran .iso.

But same error keeps coming.

I found way around above problems, by copying extracted .iso on D:\ and installing Ubuntu using wubi.exe and though on boot it was shown with Windows 7, selecting it caused following error:

  • Try hd(0,0): NTFS5 : No wubildr Try hd(0,1): NTFS5 :

So, I uninstalled it and reinstalled it

  • Now installation fails at around 7mins saying

    An error occurred. No space left on device. For more info please see log file

My D: is a 9 GB partition. (99% Free)

Ubuntu Site 12.10 says it needs around 4.5 GB.

  • Now trying it by extendin D: to 10 GB...

  • Got No wubildr.

share|improve this question
    
It seems like you have a number of issues. First is booting Ubuntu from a USB. Second is installing with Wubi from USB. Third installing Wubi with ISO together. Fourth is Wubi's grub4dos not finding wubildr. Fifth installing when \ubuntu exists. Sixth installing without enough free space. Seventh, back to the wubildr problem. I recommend identifying clearly what you want answered. –  bcbc Oct 30 '12 at 14:11
    
Thanks for responding. –  tdc2bdc Nov 1 '12 at 17:08
    
Thanks for responding. Last thing I tried is to install it on formatted pendrive through wubi. It took around 9.16 GB. But on boot wubildr isn't found. I checked from bcdedit the partition and wubildr address. They are fine. (howtogeek.com/howto/20340/…). I've a i386 iso, a 16 GB pendrive (my dvd/cd drives don't work) and a 10 GB Partition. My 32-bit PC is Pentium 4 2.4 Ghz, 1 GB RAM with Windows 7 on the other 30 GB partition. I'm first timer at Linux. With the resources stated above tell me how to run Ubuntu. Please help. Thank You. –  tdc2bdc Nov 1 '12 at 17:47
add comment

1 Answer

up vote 0 down vote accepted

Here's my advice: Either run wubi.exe standalone or Dowload the desktop ISO, save it in the same folder as wubi.exe, make sure they're from the same release, and run Wubi.

Do not install Wubi from CD or USB - or even have an Ubuntu CD or USB inserted in your computer (it will find them and use them). The former needs a workaround, and the last time I tried the latter, it tried to copy the entire USB partition as the ISO and that can be 2-16GB.

If you see:

Try hd(0,0): NTFS5 : No wubildr 
Try hd(0,1): NTFS5 :

This means that wubi can read the first partition hd(0,0) (= /dev/sda1) and there is no wubildr there (which is normal if it's a recovery or boot partition). And it means that wubi is hanging when attempting to read the second partition hd(0,1) (= /dev/sda2). I don't know why, but it does that sometimes - rarely. If I were you, I'd boot from that USB you have, mount /dev/sda2 and /dev/sda1 and copy /wubildr to it.

sudo mkdir /mnt/sda2
sudo mkdir /mnt/sda1
sudo mount /dev/sda2 /mnt/sda2
sudo mount /dev/sda1 /mnt/sda1
sudo cp /mnt/sda2/wubildr /mnt/sda1/wubildr
sudo umount /mnt/sda2
sudo umount /mnt/sda1
sudo rmdir /mnt/sda2
sudo rmdir /mnt/sda1

That should get wubildr (grub2) going.

If you have a spare paritition (D:) then I would actually recommend just installing directly to it, rather than use Wubi. It's much better, if you can handle Ubuntu being in control of your boot process (make a windows repair cd before so you can replace the windows bootloader if you want to uninstall later). But if you have to use Wubi then you can use the above techniques.

share|improve this answer
    
First of all thanks for responding so quickly. I tried once again as you suggested: 1. Formatted D:\. 2. Copied Wubi & ISO to it. 3. Removed USB. 4. Ran Wubi with internet connected.* it installed under 5.5 GB 5. Checked bcdedit. 6. Reboot. Result: Try hd (same as you mentioned) Then I made USB from UNetbootin & opted for boot from USB. Result: A disk read error has occurred. USB made from Universal-USB-Installer-1.9.1.4 gives same or simply "Boot Error" if I recall exactly. Should I try 12.04 or 12.10 LTS? I can't remove Windows at present. Thank you very much once again. –  tdc2bdc Nov 3 '12 at 13:55
    
I will also try wubi standalone later as I've exhausted my internet data pack so speed is too slow. Thanks –  tdc2bdc Nov 3 '12 at 13:57
    
You should run an MD5 check on the ISO you're using to create the USB. It's probably invalid if you're getting boot errors: help.ubuntu.com/community/HowToMD5SUM#MD5SUM_on_Windows –  bcbc Nov 3 '12 at 16:41
    
Thanksagain.Just checked MD5 with "winMD5Sum" and "Checksums calculator".Both found it identical with official one.BTW wubi-12.10-rev273 log says:11-03 05:17 ERROR CommonBackend: The md5 of the metalink does match 11-03 05:17 ERROR CommonBackend: Cannot authenticate the metalink file, it might be corrupt None 11-03 05:17 DEBUG TaskList: #### Finished get_metalink 11-03 05:17 DEBUG TaskList: New task get_file_md5 11-03 05:17 DEBUG TaskList: #### Running get_file_md5... 11-03 05:17 DEBUG TaskList: #### Finished get_file_md5 11-03 05:17 DEBUG TaskList: ### Finished check_iso.Normal? –  tdc2bdc Nov 3 '12 at 18:26
    
That says that the metalink is corrupted. So no, it's not normal. It means that it had to skip the MD5 check on the ISO so it's not conclusive that the ISO is corrupt as well. Since you manually checked the ISO, you know it's good. But since you can't boot from the USB, maybe there was a problem creating it. Did you use the instructions here?: ubuntu.com/download/help/create-a-usb-stick-on-windows Just trying to figure out why you can't boot from it. –  bcbc Nov 3 '12 at 22:11
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.