Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

As the Title indicates I have some problem with delicate movement of the mouse in Ubuntu fresh installation.

The jerkiness is shown more at small and slow movements when the mouse will move a 2 millimeters to any random positions every 5 centimeters of movements. My mouse is a Microsoft Sidewinder Gaming mouse.

Is there any driver I can use to fix it or any configuration? This is happening both in Unity or inside games and programs.

share|improve this question
    
i have the same problem, what exactly did you change? – user112952 Dec 6 '12 at 1:39
up vote 5 down vote accepted

You may try this to check mouse parameters :

Open a terminal and Run this command:

xinput --list --short

output :

abcd@abcd-abcde:~$ xinput --list --short

Virtual core pointer

↳ SynPS/2 Synaptics TouchPad                id=11   [slave  pointer  (2)]

↳ Logitech USB RECEIVER                     id=12   [slave  pointer  (2)]

for me my pointing devices are a Lgitech usb reciver and synaptic touchpad

To list out device Properties :

xinput --list-props "SynPS/2 Synaptics TouchPad"

check properties like acceleration deceleration and see if they seam allright:

if you need to change any value like suppose this one :

Device Accel Constant Deceleration (267):   2.500000

using this command :

xinput --set-prop "SynPS/2 Synaptics TouchPad" "Device Accel Constant Deceleration" 1.5

You may have to play around with this number a bit to set it exactly as you need.

If you need to set this value automatically every time Ubuntu starts then :

create a .sh file

 #!/bin/sh

 "SynPS/2 Synaptics TouchPad" "Device Accel Constant Deceleration" 1.5

change the file to executable :

 chmod +x

and Put this in the start-up applications list.

share|improve this answer
    
that helped thank you :) – Ba7a7chy Nov 6 '12 at 11:01

Looking at the mouse settings via the GUI, I found they were set to lowest possible acceleration, and lowest possible sensitivity. So I changed them using the GUI app and so far it's working just fine (after 5 mins)

share|improve this answer

Check out Pointing Devices in the software center and use settings there (it has a GUI). My mouse has since calmed down.

share|improve this answer

My Dell Inspiron One has a touch screen, I disabled it and now my mouse is behaving normally. If your computer has a touch screen try disabling it or adjusting the sensitivity.

share|improve this answer
1  
Sorry, this is not a sufficient answer. It could only works if people have a touch screen, but in the question is not mentioned. Next time, please read with care the question. – Danibix Apr 20 at 20:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.