Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated packages last night like I do every night, and when I booted my computer this morning I had a problem whereby the display ran over the edge of the screen. This has been a problem for a while, but I rectified it by changing a setting on the nVidia program, however I think it has been updated to remove said feature as I can't find it anymore. I have no settings on my screen to adjust this either, so I'm sorta stuck without the ~20px around the contour of my screen. It is a problem at all available resolutions.

Here's a lil' pic of my problem:

screen scaling irl

Probably also worth mentioning the screen was originally detected as "Laptop" in the Display setting and had many resolutions to choose from, however now it's displayed as "OEM" and only has three.

After a very lengthy Google search, I'm yet to find a solution. The most promising solution I've came across is the command xrandr --output LVDS --mode 1920x1080 --scale 1.25x1.25, however it returns the error warning: output LVDS not found; ignoring. If there's no solution, is there some sort of system rollback in Ubuntu that I could use to restore the previous configuration?

share|improve this question
    
Your link gives HTTP Error 403. –  hexafraction Oct 29 '12 at 17:17
    
edited as requested. –  Glenbot3000 Oct 29 '12 at 17:20
    
Now the Google Doc requires permissions to access. Please set permissions so anyone can access with link. –  hexafraction Oct 29 '12 at 17:21
    
Could you upload it to imageshack for instance? It may be simplier :) –  Addison Montgomery Oct 29 '12 at 17:24
    
You can upload the image right through the rich text editor. It's preferred so that AskUbuntu is responsible for keeping it for future reference. –  Kyle Macey Oct 29 '12 at 17:24

1 Answer 1

Are you using RestrictedDrivers ( BinaryDriverHowto/Nvidia ), because these can be the source of the problem sometimes. For me the factory drivers proved best, on GTS 450.

http://postimage.org/image/u140p1zff/

Perhaps try switching back, from Settings, Additional Drivers (Xubuntu 12.04.1). Otherwise, setting 'Resolution' (and refresh) from NVIDIA X Server Settings might do the trick; instead of using auto.

PS. If you can't 'Save to X Configuration File' from the nVidia utility it usually means that X had been modified by some other means and Ubuntu is reading the settings from somewhere else now (in my experience :))

Edit: Btw., just noticed a LOT of 'related' on the right after posting.

share|improve this answer
    
I'm using the drivers as provided on the nVidia website (I can't work out if that means they're restricted drivers), and switching between "version current" and "post-release updates" makes no difference. The way I made it work before was with a slider in the X Server Settings program, but it seems to have disappeared... –  Glenbot3000 Oct 29 '12 at 20:57
    
Just noticed the reply, now, apologies; but, for anyone else: the packages: "nvidia-current" and/or "nvidia-settings" are all that is needed to get the video drivers set up (no downloads from the nVidia site, or anywhere else :)). –  Nostromov Sep 28 '13 at 23:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.