Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed 12.04 on an HP Spectre XT ultrabook. I installed 12.04 from a USB. When the install was complete, and the computer restarted, I got a blank screen.

After some searching, I found that I had to choose "acpi=off" during the installation, which now shows up in the grub screen.

Once I was on 12.04, I upgraded to 12.10.

The issue now is that when I hit shutdown, the computer hangs on a purple shutdown screen. Usually, at this point, I press the power button on the machine to completely power off the machine.

I am new to ubuntu, and would appreciate the help. Thanks.

share|improve this question
add comment

2 Answers

I have two machines running Ubuntu. I modified my grub menu on the HP Spectre XT ultrabook to mirror my other machine.

I changed the following lines, from:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX="acpi=off"

To

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX=""

After doing this, my machine successfully shut down.

There was another problem, when the machine boots up, the LCD backlight is completely dark. I have to increase the brightness using keys on my keyboard, and I am then able to see the login screen.

share|improve this answer
add comment

This has been happening to me every once in a while on my Toshiba Satellite L300D laptop since 12.04 and it occurred a couple of times to me after installing 12.10. On my computer it didn't happen all the time. I'd estimate about 1 in 15 shutdowns would result in an endless purple screen that required holding down the power button to force a shutdown of the computer.

It hasn't happened for a while now, however, and I think it has something to do with my recently having disabled the "speech-dispatcher" service at start-up (It always seemed like the last thing Ubuntu would try to shutdown before hanging.

I have no reason why this would have helped, but if you want to give it a try, it can't hurt anything (unless you need your computer to talk to you!)

Install Boot-up Manager (BUM)

$sudo apt-get install bum

Open boot-up manager from the dash and then uncheck the box beside "speech-dispatcher" save and quit. At the very least you will save yourself some RAM and make your boot-up and shutdown times quicker, and hopefully solve stop the shutdown from hanging (fingers crossed!)

All that said, even if it works it is just a work-around. I think this is a bug and needs to be reported.

Cheers.

share|improve this answer
    
Thank you Matt. I found a solution just before I saw your message. Thanks again. –  rahi Oct 30 '12 at 14:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.