Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have the NVIDIA display driver from CUDA 5.0 Pre-release (on a SONY vaio) installed with 12.04. X works fine, but I if I press Ctrl+Alt+F1 the screen turns black and no login prompt appears. Its definitely a graphic driver issue because the screen is completely black. Not even a blinking text cursor. Just black, I can switch back to X however. That's fine.

I'd like to upgrade and install the NVIDIA display driver from the CUDA 5.0 production release. But here comes the tricky part: The new display driver can only be installed with no X running. However, if I run init 1 (to turn off X, networking, etc.) the screen remains black. I have to reboot in this situation.

Now, if I change the default runlevel temporarily to 1 so that X doesn't start, then I fear that the display driver cannot display anything just like in the above cases. And this would be very bad since then I don't know how to recover from this state. And actually it is very likely that I run into this because there was never a text output seen on my system when NVIDIA driver is active.

What are my options?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I believe that the driver is started along with X itself as such it should not start if the computer boots directly into runlevel 1 that said this is assuming it really is the driver causing the issue here which I can't confirm for sure.

If it helps I can give you an option to recover if you decide to try it and it fails, before you start download the latest live CD and have a copy burned ready to go on standby. Booting using that will allow you to mount your hard drive partition and reverse the configuration change. I would recommend having a live CD handy any time that you are making changes to the systems boot configuration, it's very easy for something to go wrong always best to have a plan to recover.

Hope that helps, not sure what else to suggest beyond that.

share|improve this answer
    
I set the default runlevel to 1 and the system comes up in text mode. (There is nvidia listed when doing lsmod). However the driver doesn't install in RL 1. Damn! Is there a way to go to RL 2 but artificially skip X ? –  Frank Oct 29 '12 at 13:36
    
Ok, I managed to install the release driver. I returned to a non-nvidia, non-nouveau graphic driver (by blacklisting) and then was able to go to console, shutdown X, install the new driver. –  Frank Oct 29 '12 at 13:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.