Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed yesterday Ubuntu 12.10 32-bit version (as recommended) on my laptop. It was a fresh install, alongside Windows XP. On grub, after choosing normal boot on ubuntu, it starts loading things, but before starting the Ubuntu loading screen (with the dots) it stops flashing HDD activity led, and hangs there, and I need to hard shutdown the laptop. However, if I choose recovery mode on grub, and then choose Normal Boot on the options screen, it starts, but it doesn't allow to choose the native screen resolution (1440x900).

How can I solve the problem on normal boot? How can I grab more information about the reason it hangs? I thought that starting in recovery mode it showed the reason, but it starts and doesn't hang, so I can't extract any information about the issue.

Can you help me?

Thank you!

share|improve this question

4 Answers 4

up vote 1 down vote accepted

Please read here how it is solved: (I haven't tried yet, I'm just posting someone's solution)

http://askubuntu.com/a/211040/101867

share|improve this answer
    
This was a bug, that was fixed, see bugs.launchpad.net/ubuntu/+source/linux/+bug/1180557/comments/8 –  Beamie Jul 18 at 18:39

I had this before.

Try to do this in your terminal:

sudo nano /etc/default/grub

Look for:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it too :

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

And update Grub:

sudo update-grub

This should fix stuff.

share|improve this answer
    
Thank you for the reply. I'll do that, and then post the result, and if that solved the issue. –  jorgedso Oct 30 '12 at 11:48
    
Well, I did what you suggested, but it didn't work. I also tried to start without "quiet" and also without "splash", and I noticed that it hangs in the moment the characters appearance changes. However, the line shown when that happens is this one: Adding 7812092k swap on /dev/sda2. Priority:-1 extents:1 across:7812092k Does this tell something about the problem I am facing? –  jorgedso Oct 30 '12 at 21:51
    
Now, I tried adding "nomodeset" parameter at the grub line, and it booted in normal mode correctly. However, it still doesn't allow me to select 1440x900 native screen resolution. My graphics card is an ATI Mobility Radeon x2300 (M64S). In Ubuntu 11.10 it allows me to choose the native resolution. How changed in 12.10 for me not to be able to select native resolution? –  jorgedso Oct 30 '12 at 22:22
    
well, that's an entirely different question. But I have an AMD graphics card too, and AMD isn't supported in linux. you better get a nvidia, since that works perfectly, but I can't help with that. And for the booting, you installed amd drivers? since from my expirience, that only screws things up..... –  Dr_Bunsen Oct 31 '12 at 7:30
    
Next step I will try is to install fglrx to see if it works right... I've been reading about this graphics card and it seems it is somewhat the "ugly duckling", because is not supported in the AMD proprietary drivers. –  jorgedso Oct 31 '12 at 10:13

Because the drivers (fglrx) are supported only to Xorg server version 1.12, and Ubuntu 12.10 comes with Xorg server version 1.13, it doesn't work.

Read here: What is the correct way to install ATI Catalyst Video Drivers?

So, the solution is either downgrade Xorg version to 1.12 and keep Ubuntu 12.10 or stick with Ubuntu 12.04 and wait until fglrx supports Xorg version 1.13 and then upgrade to 12.10.

share|improve this answer

It's correct that the proprietary drivers from ATI wont support your card Radeon x2300 Mobility after 12.04 as discussed above. ATI dropped support,and there are some hacks floating around on how to downgrade x-server and stuff and maybe get it working in versions above 12.04 - I never did. Did you?

However, the open source driver does work, and it works quite ok for this card up until kernel 3.2x - unfortunately, after that it seems some regression has sneaked in and it hasn't worked since. 12.10 use kernel 3.5x-series, 13.04 uses 3.8x series and the problems still there. Maybe you could help out with a bugreport here. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1180557

WORKAROUNDS: If you add "nomodeset" in your boot-config after "quiet splash" it will probably work, but you'll get low-resolution etc. Or, if you upgraded Ubuntu from 12.04 and kept your old kernels, you can boot even 13.04 with the 3.2x kernel. I do, and no visible problems so far. That's the solution I Would recommend for now. (And reporting the regression)

UPDATE: This problem is now a confirmed bug, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1180557 and seems to be upstreams,and even in the latest kernels for next version of Ubuntu. Hope they fix it before relase.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.