Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 10.04. Before the upgrade, I was using multiple windows, and I was able to drag applications across the windows. But, now the windows are locked. Further, the icon of the maximized window is not showing. Just a generic window icon.

share|improve this question

closed as too localized by Luis Mar 14 '13 at 17:04

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
do you mean monitors? –  myusuf3 Aug 12 '10 at 20:27
    
I think he is talking about multiple workspaces. There you should indeed be able to move applications around and the workspace switcher should show an icon of the maximized window. –  Marcel Stimberg Aug 12 '10 at 20:36
    
This question is unclear. Please clarify it (add annotated screenshots?). –  Li Lo Aug 13 '10 at 3:46

4 Answers 4

If you meant monitors.

System > Preferences > Monitors

Make sure they are on and same Image on monitors is checked off.

If you meant workspace you can move any application by right clicking on the task bar and assigning it to the desired workspace.

Hope it works :)

share|improve this answer

You need to be running compiz to drag windows across your virtual desktops.

Metacity doesn't have this behaviour (by default anyway), although you can change what workspace a window is on by right clicking the title bar.

To enable compiz:

  1. Go to System -> Administration -> Hardware Drivers and make sure you have graphics drivers (if available) installed and enabled.
  2. Right Click on the desktop and click 'change desktop background' or go to System -> Preferences Appearance
  3. Click the 'Visual Effects' tab, select custom and click 'Preferences'
  4. Edit your compiz preferences. You can choose Edge behaviour in the 'Edge' tab. Also enabling the Desktop Cube in the 'Desktop' tab allows you to drag windows between desktops.
share|improve this answer

Sounds like you window manager has died. This happend on a few machines for me when upgrading from 9.10 to 10.04. You can fix this by opening a terminal (application-accessories-terminal) and typing:

metcity --replace

or if your graphic card supports 3D acceleration then tyrp:

compiz --replace

then close all open windows and go to system-settings-start up programs-settings and press the button labled "Remember currently running programs".

share|improve this answer

I understand it like if you are using multiple workspaces

Drag windows over workspaces:

Note: In order to drag windows across workspaces you do not need 3d enabled.

  1. Install ccsm in software center. (Advanced desktop effects settings)
  2. List item
  3. Goto System -> preferences -> compizcompiz settings manager
  4. Then choose: Desktop wall -> Edge flipping
  5. The functionality you are looking for is called "edge flip move" so toggle that

Resetting the desktop switcher in the panel:

  1. Right click it and select remove from desktop
  2. Riht click the panel and select "add to panel"
  3. Then add the workspace switcher move it position and lock it to the panel.

If your having multiple issues after upgrade to 10.04 i recommend doing a backup and reinstalling a fresh version of it. If it's only this you should be fine.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.