Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a Samsung Series 5 Ultra 2 weeks ago and installed Ubuntu 12.04 LTS. I am experiencing problems with overheating. When streaming, watching a movie or when having several programms/actions going on at the same time the CPU temperature rises to 95 degrees and the computer freezes. This happens sometimes when the computer is on battery and always when it is recharging. When I am using the computer on battery the CPU temperature is floating from around 75-95 degrees depending what it's doing. When the battery is recharging the CPU temperature is ranging from 88-95 degrees no matter what tasks it performs.

Have anyone experienced this and how may the problem be solved?

Best regards

share|improve this question
    
Check whether problem from the battery by removing the battery and giving direct power supply. –  vembutech Mar 10 at 21:06

3 Answers 3

You should consider installing jupiter

You can select power modes with it, it's very easy to control, just set it to power on command, you wont notice that your laptop is on, until you start using heavy apps. Plus it will stay way cooler.

open terminal and do this:

add the repository

sudo add-apt-repository ppa:webupd8team/jupiter

update

sudo apt-get update

install jupiter

sudo apt-get install jupiter

and to other people reading this and are using an Asus EEPC netbook, install this asswell

sudo apt-get install jupiter-support-eee

Have a nice day :)

share|improve this answer

Here you can find a script to throttle your CPU frequency based on temperature. You set a max temperature, and if your system goes over that temperature it slows down your CPU(s).

http://seperohacker.blogspot.com/2012/10/linux-keep-your-cpu-cool-with-frequency.html

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Nov 19 '12 at 16:47

Until today I had the same problem. It seems instel_pstate which regulates thermal issues on newer intels is no longer enabled by default. Assuming you have intel cpus you might be suffering the same problem.

I solved it by installing enabling pstate & installing thermald.

http://www.webupd8.org/2014/04/prevent-your-laptop-from-overheating.html

share|improve this answer
    
Although your answer is 100% correct, it might also become 100% useless if that link is moved, changed, or the main site just disappears... :-( Therefore, please edit your answer, and copy the relevant steps from the link into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link in at the bottom of your answer as a source for your material... –  Fabby Mar 10 at 21:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.