Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i try to execute sudo apt-get install rubygems i get the following response

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-30 linux-headers-3.2.0-30-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  build-essential dpkg-dev fakeroot g++ g++-4.6 libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libdpkg-perl libreadline5 libruby1.8
  libstdc++6-4.6-dev ruby1.8 ruby1.8-dev
Suggested packages:
  debian-keyring g++-multilib g++-4.6-multilib gcc-4.6-doc libstdc++6-4.6-dbg libstdc++6-4.6-doc ruby1.8-examples ri1.8
The following NEW packages will be installed:
  build-essential dpkg-dev fakeroot g++ g++-4.6 libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl libdpkg-perl libreadline5 libruby1.8
  libstdc++6-4.6-dev ruby1.8 ruby1.8-dev rubygems
0 upgraded, 15 newly installed, 0 to remove and 0 not upgraded.
Need to get 12.5 MB of archives.
After this operation, 41.5 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  libreadline5 libstdc++6-4.6-dev g++-4.6 g++ libdpkg-perl dpkg-dev build-essential fakeroot libalgorithm-diff-perl libalgorithm-diff-xs-perl libalgorithm-merge-perl
  libruby1.8 ruby1.8 ruby1.8-dev rubygems
Install these packages without verification [y/N]? y
Err http://in.archive.ubuntu.com/ubuntu/ precise/main libreadline5 amd64 5.2-11
  Could not connect to 111.125.139.199:8105 (111.125.139.199). - connect (111: Connection refused)
Err http://in.archive.ubuntu.com/ubuntu/ precise/main libstdc++6-4.6-dev amd64 4.6.3-1ubuntu5
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise/main g++-4.6 amd64 4.6.3-1ubuntu5
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise/main g++ amd64 4:4.6.3-1ubuntu5
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise/main libdpkg-perl all 1.16.1.2ubuntu7
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise/main dpkg-dev all 1.16.1.2ubuntu7
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise-updates/main build-essential amd64 11.5ubuntu2.1
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise/main fakeroot amd64 1.18.2-1
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-diff-perl all 1.19.02-2
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-diff-xs-perl amd64 0.04-2build2
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise/main libalgorithm-merge-perl all 0.08-2
  Unable to connect to 111.125.139.199:8105:
Err http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libruby1.8 amd64 1.8.7.352-2ubuntu1.1
  Unable to connect to 111.125.139.199:8105:
Err http://security.ubuntu.com/ubuntu/ precise-security/main libruby1.8 amd64 1.8.7.352-2ubuntu1.1
  Could not connect to 111.125.139.199:8105 (111.125.139.199). - connect (111: Connection refused)
Err http://security.ubuntu.com/ubuntu/ precise-security/main ruby1.8 amd64 1.8.7.352-2ubuntu1.1
  Unable to connect to 111.125.139.199:8105:
Err http://security.ubuntu.com/ubuntu/ precise-security/main ruby1.8-dev amd64 1.8.7.352-2ubuntu1.1
  Unable to connect to 111.125.139.199:8105:
Err http://security.ubuntu.com/ubuntu/ precise-security/main rubygems all 1.8.15-1ubuntu0.1
  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/r/readline5/libreadline5_5.2-11_amd64.deb  Could not connect to 111.125.139.199:8105 (111.125.139.199). - connect (111: Connection refused)
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.6/libstdc++6-4.6-dev_4.6.3-1ubuntu5_amd64.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/g/gcc-4.6/g++-4.6_4.6.3-1ubuntu5_amd64.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/g/gcc-defaults/g++_4.6.3-1ubuntu5_amd64.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/d/dpkg/libdpkg-perl_1.16.1.2ubuntu7_all.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/d/dpkg/dpkg-dev_1.16.1.2ubuntu7_all.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/b/build-essential/build-essential_11.5ubuntu2.1_amd64.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/f/fakeroot/fakeroot_1.18.2-1_amd64.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/liba/libalgorithm-diff-perl/libalgorithm-diff-perl_1.19.02-2_all.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/liba/libalgorithm-diff-xs-perl/libalgorithm-diff-xs-perl_0.04-2build2_amd64.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/liba/libalgorithm-merge-perl/libalgorithm-merge-perl_0.08-2_all.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/r/ruby1.8/libruby1.8_1.8.7.352-2ubuntu1.1_amd64.deb  Could not connect to 111.125.139.199:8105 (111.125.139.199). - connect (111: Connection refused)
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/r/ruby1.8/ruby1.8_1.8.7.352-2ubuntu1.1_amd64.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/r/ruby1.8/ruby1.8-dev_1.8.7.352-2ubuntu1.1_amd64.deb  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://security.ubuntu.com/ubuntu/pool/main/r/rubygems/rubygems_1.8.15-1ubuntu0.1_all.deb  Unable to connect to 111.125.139.199:8105:
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Following questions can be linked to the similar error:-

Error in updating the system ,

gerrit push not working ,

Printer Add button not enabled ,

apt-get install not working ,

unable to fetch git from eclipse

Please someone help on this, this error is not letting me install anything in my system

share|improve this question
1  
It is temporary error from server. You can Choose another mirror for it. –  K.K Patel Oct 29 '12 at 5:59
    
it's not temporary error, it has been there for many many days.. i tried changing the server too –  vipin8169 Oct 29 '12 at 6:00
1  
which server you tried ? have to tried glug.nith.ac.in whichis fastest mirror in India. –  K.K Patel Oct 29 '12 at 6:03
1  
Try out another mirror out of India. –  K.K Patel Oct 29 '12 at 6:09
1  
let us continue this discussion in chat –  K.K Patel Oct 29 '12 at 6:11
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.