Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two laptops sitting next to each other, both running Kubuntu 12.04, and my goal here is to share files between them using Zeroconf networking. Here's what the wiki says about how to configure Zeroconf in Kubuntu:

Procedure 1. ZeroConf Configuration

Open System Settings by going to KMenu → System Settings.

Select Network Settings.

In the left hand side of the Network Settings dialog, select the Zeroconf Service Discovery option.

If the Enable Zeroconf network browsing or the Browse local network options are not selected, please select them now and press the Apply button.

The trouble is that the Network Settings dialog does not have a Zeroconf Service Discovery option. It does have a Service Discovery option but it's all greyed out. Zeroconf does seem to be installed, and the routing table has an entry for 169.254.0.0.

I have a feeling that everything I need is there, but I can't figure out how to use it.

share|improve this question

1 Answer 1

It's likely that almost everything you need is present, but not quite. Try installing the avahi and libnss-mdsn packages, then log out & back into kubuntu:

sudo apt-get install avahi-daemon libnss-mdns 

Once you do that, the options should no longer be greyed out.

More information can be found here:

https://wiki.kubuntu.org/KubuntuZeroconf

share|improve this answer
    
I've got avihi-daemon and libnss-mdns installed, and in fact I had them installed all along. What I didn't know is that I can access any machine on my local net as hostname.local -- I learned that from the zeroconf page that you so kindly referred me to. That was the critical piece of information I needed. I assume that it's zeroconf that did that for me, so the local names probably were there all along. –  user101815 Nov 9 '12 at 0:13
    
But the Service Discovery page still has only greyed-out options, and no data. That probably doesn't matter at this point. –  user101815 Nov 9 '12 at 0:15
    
Glad I could help a little! Go ahead and post your solution as a separate answer to your question, then mark it as accepted. –  ImaginaryRobots Nov 9 '12 at 16:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.