Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've been trying to compile this app from source and i keep getting this message when i run MAKE:

Scanning dependencies of target gala 
[ 11%] Building C object CMakeFiles/gala.dir/src/DBus.c.o 
/home/camilo/notifications/build/src/DBus.c:21:18: fatal error: glib.h: No such file or directory 
compilation terminated. 
make[2]: *** [CMakeFiles/gala.dir/src/DBus.c.o] Error 1 
make[1]: *** [CMakeFiles/gala.dir/all] Error 2 
make: *** [all] Error 2

Even though I' have installed glib and there is the glib.h file

camilo@ian:~$ find /usr -iname glib.h

Is it a bug form the application or is it something wrong with my system?

share|improve this question
Compiler doesn't know the path of glib.h. Use CFLAGS='-I/usr/include/glib-2.0' option with make command and compile – devav2 Oct 29 '12 at 6:20

1 Answer 1

I solved it. The issue was i didn't have installed the gsettings-desktop-schemas-dev Install gsettings-desktop-schemas-dev package.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.