Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install Support for MPI-based distributed emulation (sudo apt-get install openmpi*) but I can't. terminal says:

error@ubuntu:~$ sudo apt-get install openmpi*
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libopenmpi1.6-dbg' for regex 'openmpi*'
Note, selecting 'libmeep-openmpi6' for regex 'openmpi*'
Note, selecting 'libopenmpi1.6-dev' for regex 'openmpi*'
Note, selecting 'libmeep-openmpi-dev' for regex 'openmpi*'
Note, selecting 'libhdf5-openmpi-7' for regex 'openmpi*'
Note, selecting 'meep-openmpi' for regex 'openmpi*'
Note, selecting 'libhdf5-openmpi-7-dbg' for regex 'openmpi*'
Note, selecting 'openmpi1.6-common' for regex 'openmpi*'
Note, selecting 'openmpipython' for regex 'openmpi*'
Note, selecting 'yorick-mpy-openmpi' for regex 'openmpi*'
Note, selecting 'gromacs-openmpi' for regex 'openmpi*'
Note, selecting 'mpqc-openmpi' for regex 'openmpi*'
Note, selecting 'libopenmpi1.3' for regex 'openmpi*'
Note, selecting 'libopenmpi1.6' for regex 'openmpi*'
Note, selecting 'openmpi-checkpoint' for regex 'openmpi*'
Note, selecting 'octave-openmpi-ext' for regex 'openmpi*'
Note, selecting 'libhdf5-openmpi-dev' for regex 'openmpi*'
Note, selecting 'openmpi-libs0' for regex 'openmpi*'
Note, selecting 'openmpi1.6-bin' for regex 'openmpi*'
Note, selecting 'openmpi-mpidoc' for regex 'openmpi*'
Note, selecting 'netpipe-openmpi' for regex 'openmpi*'
Note, selecting 'libhdf5-openmpi-1.8.4' for regex 'openmpi*'
Note, selecting 'libhdf5-openmpi-1.8.6' for regex 'openmpi*'
Note, selecting 'libhdf5-openmpi-1.8.7' for regex 'openmpi*'
Note, selecting 'openmpi1.6-doc' for regex 'openmpi*'
Note, selecting 'openmpi-bin' for regex 'openmpi*'
Note, selecting 'openmpi-dbg' for regex 'openmpi*'
Note, selecting 'openmpi-dev' for regex 'openmpi*'
Note, selecting 'openmpi-doc' for regex 'openmpi*'
Note, selecting 'openmpi-common' for regex 'openmpi*'
Note, selecting 'libopenmpi-dbg' for regex 'openmpi*'
Note, selecting 'libopenmpi-dev' for regex 'openmpi*'
Note, selecting 'openmpi1.6-checkpoint' for regex 'openmpi*'
Note, selecting 'libopenmpi1' for regex 'openmpi*'
Note, selecting 'libopenmpi2' for regex 'openmpi*'
Note, selecting 'libopenmpi-dev' instead of 'openmpi-dev'
Note, selecting 'libopenmpi-dbg' instead of 'openmpi-dbg'
Note, selecting 'libopenmpi1.3' instead of 'openmpi-libs0'
Note, selecting 'openmpi-doc' instead of 'openmpi-mpidoc'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libopenmpi1.6 : Conflicts: libopenmpi1.3 but 1.4.5-1ubuntu1 is to be installed
                 Conflicts: openmpi-libs0
 libopenmpi1.6-dbg : Conflicts: libopenmpi-dbg but 1.4.5-1ubuntu1 is to be installed
                     Conflicts: openmpi-dbg
 libopenmpi1.6-dev : Conflicts: libopenmpi-dev but 1.4.5-1ubuntu1 is to be installed
                     Conflicts: openmpi-dev
 openmpi1.6-bin : Conflicts: openmpi-bin but 1.4.5-1ubuntu1 is to be installed
 openmpi1.6-checkpoint : Conflicts: openmpi-checkpoint but 1.4.5-1ubuntu1 is to be installed
 openmpi1.6-common : Conflicts: openmpi-common but 1.4.5-1ubuntu1 is to be installed
 openmpi1.6-doc : Conflicts: openmpi-checkpoint (< 1.6.4-1) but 1.4.5-1ubuntu1 is to be installed
                  Conflicts: openmpi-doc but 1.4.5-1ubuntu1 is to be installed
                  Conflicts: openmpi-mpidoc
E: Unable to correct problems, you have held broken packages.
share|improve this question

1 Answer 1

Lots of the openmpi packages are mutually exclusive. You can't just install them all, like that.

Also, note that ns3 wasn't build with MPI support, in Ubuntu. So installing these won't help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.