Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm connected to my wireless network but am unable to connect to the internet. It appears I do not have an IP address and I'm not sure what to do. I had working internet until I booted up this morning. What is the best way to fix this in Ubuntu 10.04

share|improve this question
    
Try to connect internet using same wifi router on another system. If it also goes fail, then there is a problem with router configuration. –  K.K Patel Oct 29 '12 at 5:41
    
There are several devices (computers and smartphones) connected with working connections. I've given myself a static IP and that worked for a while but has stopped as well. –  1eca Oct 29 '12 at 7:33
    
By using router or defined only on your system.. It may due to different Ip –  K.K Patel Oct 29 '12 at 7:36
    
I defined the IP on my system alone. I gave myself an IP that was given to me by the router when I was able to connect to the internet. –  1eca Oct 29 '12 at 16:16
    
Conform that ip again... It should be changed. –  K.K Patel Oct 29 '12 at 16:59
show 1 more comment

2 Answers

I know it sounds dumb, and I am by no means an expert, but have you tried resetting your computer or router? Also, have you tried the new LTS release 12.04? You can try it via a live usb and see if it fixes your issue. If so, you may want to consider upgrading. Furthermore, did you install any programs or updates before you last shutdown the computer?

I know the above sounds like your standard IT suggestions, and are perhaps obvious, but if you haven't tried them you may be pleasantly surprised. In my experience as an "average user" (with limited command line knowledge), often a simple restart fixes the problem. Also, try reconnecting to the network and pining sites to "force" an internet reconnection.

share|improve this answer
    
I've tried several restarts on both my computer and the router. I don't know how I feel about upgrading (I actually have been contemplating downgrading back to 10.10) I've tried pinging various sites with 100% packet loss. –  1eca Oct 29 '12 at 7:36
add comment

Things to try...

Put your laptop on wall power.

Does the laptop have a wireless kill switch? Switch it on. Still doesn't work? Reboot.

Enter BIOS setup and make sure the Wi-Fi interface is still enabled.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.