Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently wiped my entire harddrive and switched from Windows 7 to Ubuntu 12.10 (32b - Used to have everything 64, but it said 32 was recomended?). It seems that everything BUT my sound is working as intended. As I'm pretty new to Ubuntu and have only had very minimal experience in Linux OS', what are my options?

I used sudo aplay -l to see if it recognized my sound card? And I got a TON of output listing something like 255 subdevices per device is found i'm guessing..

Not sure if that's what was suppose to happen or not.

Nothing is muted, I made sure of that by looking around on the web for help topics.

The thing is, it plays sound through my monitor speakers (HDMI) just fine, but not through my main speakers. So i'm thinking it has to be with my sound card.

Using 'pacmd list' i get a long list of stuff, but only copied some of it; Not sure if it will be useful or not.

2 card(s) available.
    index: 0
    name: <alsa_card.pci-0000_01_0a.0>
    driver: <module-alsa-card.c>
    owner module: 4
    properties:
        alsa.card = "0"
        alsa.card_name = "Creative X-Fi"
        alsa.long_card_name = "Creative X-Fi 20K1 Unknown"
        alsa.driver_name = "snd_ctxfi"
        device.bus_path = "pci-0000:01:0a.0"
        sysfs.path = "/devices/pci0000:00/0000:00:04.0/0000:01:0a.0/sound/card0"
        device.bus = "pci"
        device.vendor.id = "1102"
        device.vendor.name = "Creative Labs"
        device.product.name = "SB X-Fi"
        device.string = "0"
        device.description = "SB X-Fi"
        module-udev-detect.discovered = "1"
        device.icon_name = "audio-card-pci"
share|improve this question
    
Anyone have any info? > 01:0a.0 Multimedia audio controller: Creative Labs SB X-Fi Subsystem: Creative Labs X-Fi XtremeMusic Flags: bus master, medium devsel, latency 32, IRQ 18 I/O ports at ec00 [size=32] Memory at efe00000 (64-bit, non-prefetchable) [size=2M] Memory at e8000000 (64-bit, non-prefetchable) [size=64M] Capabilities: <access denied> Kernel driver in use: snd_ctxfi Kernel modules: snd-ctxfi –  Khris Oct 29 '12 at 20:53

2 Answers 2

Found that a user replied to someone else's thread that had the same issue and it resolved my own. Posting the link to the comment and a direct link to the website that helped me.

Thread: http://askubuntu.com/a/204280/101761 Direct: http://www.unixmen.com/2012003-howto-resolve-nosound-problem-on-ubuntu/

After I did:

 sudo add-apt-repository ppa:ubuntu-audio-dev
 sudo apt-get update
 sudo apt-get dist-upgrade

I went into the 'Sound Settings' and tested in Digital Output, which to no surprise didn't work. But to my amazement found that Analog Output DOES work. And sounds as it should.

Hope this helps someone else and major kudos to Unixmen and kudos to the user who posted http://askubuntu.com/a/204280/101761

share|improve this answer

I think that you're using your HDMI speakers instead of the computers. Go to your settings, sound and there you should see marked what is the port (or whatever it is called) that is enabled. Just click on the one that said the name of your computer's speakers and click on the "test" button and you should hear the sounds from your speakers. The same thing happened to me last week because I was using my TV and changed the settings. If is that, try it. Good luck!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.