Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Alienware M17xR3 laptop and ubuntu works great with it, except for the video. I'm using Bumblebee Project to use the discrete card. I have NVIDIA GTX 580M and from the nvidia-settings I can see that PowerMizer never raises to level 4. It goes max to level 2 and it stays there. I tried forcing the card to go max power with:

optirun nvidia-settings -q all

But it still goes only to level 2. I tried eding my /etc/bumblebee/xorg.conf.nvidia and adding this two options:

# AC settings:
Option "RegistryDwords" "PowerMizerLevelAC=0x1"
# Battery settings:
Option  "RegistryDwords" "PowerMizerLevel=0x1"

but still no effect. I'm aware of this problem for more than 2 months, but only a few days ago I decided to buy a game from ubuntu-software-center and I found out I couldn't play it at max settings. I have tried a lot more things before, but I don't remember them and they didn't help. I remember that I read in nvidia forums that this problem is due to DSD table from APIC and there was a workaround to exchange the positions of two tables... but at my side the two tables were with swapped content(compared to the person in the nvidia forums) and even though I tried exchanging their positions I got no positive results, but negative ones. I started to wonder that the easiest way would be to upgrade the bios image and see what happens, but I prefer not to do that, bacause I have more than 3 years warranty.

If someone have any ideas I'll be glad if he/she shares. And I forgot to mentioned that I used nvidia-current from ubuntu's repo and tried the newest nvidia version from 310.14 for xorg-edgers, but without any success.

Thanks in advance.

EDIT: Just to note as this is a problem more specific to NVIDIA/Linux, than Ubuntu's, I created a thread in NVIDIA's new forum for linux support. Here is the link to that thread: Thread on NVIDIA's forum

EDIT2: A lot of time has passed and no progress still. That's why I tried asking and DELL. Here is a link to my thread there: Dell's forum

EDIT3: I'm updating with a little bit more info my problem.

After installing nvidia-313 from xorg-edgers ppa I got a new problem that my BIOS didn't everytime recognize my discrete NVIDIA card. I don't think it's caused by the driver, but it's just a coincidence. So anyway I started researching it and I came accross one of the options in my BIOS in "Advanced" tab "Primary Display". It had two options "SG"(Switchable Graphics) and PEG(Peripheral Graphics). On SG I have Optimus enabled and on PEG I have only my discrete card enabled. On SG I was suffering the problem that my NVIDIA card isn't found each time, while on PEG it was found each time. So after setting Primary Display to PEG I installed again nvidia-313 package and tried PowerMizer. This time it worked. I tested with "Amnesia: The Dark Descend" and the game wasn't lagging anymore. After checking PowerMizer I confirmed that it was moving successfully between all 4 performance levels. There was something that I didn't like about it though. PowerMizer was preffering the loweest and highest performance levels. For example if I'm on the lowwest and started changing desktops, the desktop animations lag a little but PowerMizer statys in lowwest level. When doing the same when in highes level it doesn't go down.

So it looks like when Optimus is enabled PowerMizer isn't working correctly, but when it's disabled PowerMizer can use all performance levels.

share|improve this question
    
I opened a bug at launchpad. Here is a link Launchpad –  mazzzterz Jan 5 '13 at 10:39

1 Answer 1

Do you have tried changing 1 to 3

PowerMizerLevel=0x3

or try (and erase other Option "RegistyDwords".... lines)

Option  "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerLevel=0x1; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x3"

???

Try playing with 3 or 1 or 2... Good luck

share|improve this answer
1  
Thanks for taking your time answering! I did try changing them, but with no success. Powermizer can be set at lv.1 and 2 without problems. Lv.3 and 4 are out of reach. When selecting them it powermizer set's itself on lv.2. –  mazzzterz Nov 20 '12 at 20:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.