Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to stream youtube videos on my ubuntu 11.04, they don't stream smoothly. They buffer well and are choppy.

Here's my Config:

  • Laptop: Gateway NV58
  • Ram : 4 GB
  • Ethernet Controller: Broadcom Corp NetLink BCM5784M Gigabit Ethernet PCIe (rev10)

Let me know if you need more details.


Output of lspci:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
04:00.0 Network controller: Intel Corporation WiFi Link 5100
share|improve this question
    
Could you please rephrase your question? It's a little...hard to understand. Also, if the video gets choppy after some seconds/minutes, try to pause it right at the beginning and wait for the video to fully load before playing it...at least I have this issue with some (I blame Flash). –  Bobby Jan 9 '11 at 19:35
    
on my roommate's laptop (he has ubuntu 10.10 and we share the same wireless conneciton), the same video streams well. What I want to know is if I need to update my video card driver or network-driver. –  Newbie Jan 9 '11 at 19:39
    
Are you using Firefox? Does this happen with other browsers like Chromium and Opera? I see choppy flash playback too, but only in Firefox. –  htorque Jan 9 '11 at 19:49
    
Of you could rephrase the question that would really help. For example: "They buffer well..." is contradictory. Could you also add your video card information, as well as tell us how you installed flash (maybe we could know which version of flash you have). –  RolandiXor Jan 9 '11 at 19:56
    
@Roland - Sorry... I meant "the videos don't buffer well". It was a typo. I am using Chrome browser(8.0.552.224). I've tried viewing the videos in Firefox too and they are choppy there as well. And a quick question - how can I find my flash version? –  Newbie Jan 9 '11 at 20:24
show 2 more comments

3 Answers 3

Get Flash-Aid and run it. It will detect installed flash plugins, remove them and install the best option according to your system architecture and version. Additionally, it will apply some tweaks that should fix your problems. If you still get that issue after running Flash-Aid, then go to the extension Help tab, click the "Generate Report" button and send me the results so I can analyze your situation.

share|improve this answer
add comment

If you have Time Warner Cable in the US you may find that they are throttling your youtube download speed. The workaround is to block the IP addresses associated with the throttling (206.111.0.0/16)

iptables -I FORWARD -s 192.168.1.0/24 -d 206.111.0.0/16 -j REJECT

with sudo (where 192.168.1.0/24 is your LAN subnet).

(reddit source)

share|improve this answer
add comment

I asume your laptop has NVIDIA® GeForce® G105M video card. Following THIS forum thread I would try Nouveau driver. They don't describe the same problem but all this can be related. This isn't really a solution but it's worth a try.

share|improve this answer
    
I believe my laptop has Intel Video card. Here's the output of "lspci". –  Newbie Jan 9 '11 at 19:56
    
Hmm so your computer is currently using Intel card, but you do have Nvidia also. Your computer has hybrid video card (nvidia+intel). Try activate is in BOIS or with Nouveau driver. I have no experience with this hardware, but I do know people have problems with it cuz driver is relatively new. good luck! –  danizmax Jan 9 '11 at 20:19
    
@danizmax - Thanks! But I'm new to this. How can I tell it has a hybrid video card? –  Newbie Jan 9 '11 at 20:32
    
@danizmax lspci does not list an nvidia card what are you talking about? –  RolandiXor Jan 9 '11 at 20:47
    
Well not sure how this hybrid thing exactly works, but if the chips is turned off in BIOS then OS can't see it. Look here for your laptop specs support.gateway.com/s/notebook/2009/gateway/nv/nv58/… –  danizmax Jan 9 '11 at 21:06
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.