Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Last week, I upgraded my operating system to Ubuntu 12.10 from 12.04, and the internet stopped working on two virtual machines (launched with virtualbox), Windows XP and OSX Snow Leopard. OSX also stopped working completely at first, but I fixed that by switching to the 64 bit option in the vbox settings. I switching to bridged networking from NAT restored the internet to Windows, but not to OSX. Does anybody know what I could be doing wrong?

share|improve this question
up vote 2 down vote accepted

From Ubuntu 12.04 dns name resolve changed so that you should add "dns-nameservers" parameter to your /etc/network/interfaces file, like :

share|improve this answer
Thanks! Once I got the adapter back to "Intel PRO/1000 T Server (82543GC) and Vbox back to 4.1, this worked like a charm! – user100607 Oct 30 '12 at 5:17

I had exectly same issue. You need to upgrade the VirtualBox to 4.2.X (that helped me)

Add one of the following lines according to your distribution to your /etc/apt/sources.list:

deb precise contrib


wget -q -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get install virtualbox-4.2

More about installation and post install steps you can read here:

share|improve this answer
I tried this, but with 4.2 my Vbox lost the ability to load OSX. This may be because my hardware is mac, but my host OS is ubuntu. Thanks for trying, though. On the plus side, while it was in 4.2, Windows seemed to run better. – user100607 Oct 30 '12 at 5:07
I had this same problem, and this fixed it perfectly for me. In fact, it also fixed another problem I was having with Windows 3.11 displaying stretched when I increased the resolution. – Dan Jones Dec 12 '12 at 17:28

As per thread here

sudo apt-get install dnsmasq

solved the issue for me

share|improve this answer
Thank you so much! This worked perfectly for me on Xubuntu 12.10. – functionptr Feb 23 '13 at 3:05

First check how is network configured in guests if its DHCP then probably they don't get DNS servers from host as after update Virualbox has no runing DNS service for nated guests thus they can't resolve hostnames.

There are two solutions 1) Setup guest mashines to use as DNS servers or recofigure Virtualbox to provide DNS proxy service

VBoxManage modifyvm "VM name" --natdnsproxy1 on 


VBoxManage modifyvm "VM name" --natdnshostresolver1 on

Changing DNS server config in guests works for me the other solution might work (acording to VBox documentation) havent tested it myself

share|improve this answer

I was having the same problem. Using 12.10 as a host and running Windows Vista as a guest. The following solved the problem:

VBoxManage modifyvm global --natdnshostresolver1 on


share|improve this answer

I have been struggling with no network connection since upgrade to 12.10. I was getting the "DNS server is not responding" message.

sudo apt-get install dnsmasq

solved the issue for me as well.

share|improve this answer

Personally, none of the above solutions worked out in my case.

However, the following command, found here, made my day:

vboxmanage modifyvm "Your VM Name" --natdnshostresolver1 on

Hope that helps,

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.