Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Ubuntu 12.04 and have been trying to get it to detect my Micromax data card. I have been trying to install usb_modeswitch, but I keep getting the follow error -

E: Unable to locate package usb_modeswitch

I also tried editing the etc/apt/sources.list and added the following :

deb maverick main restricted universe
deb-src maverick main restricted universe

Still no improvement. What am I not doing right?

Any help will be appreciated. Thanks in advance!

share|improve this question

The package is called usb-modeswitch (with - instead of _).

The lines you have added are for Ubuntu 10.10 "Maverick Meerkat". They do not work on Ubuntu 12.04 "Precise Pangolin"

share|improve this answer
I tried usb-modeswitch. it gives the following error: E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) E: Unable to lock directory /var/lib/apt/lists/ There is no other installation/updation running. Plus, it is executing in root mode. – swapna sugunendiran Oct 28 '12 at 18:11
Have a look at Fixing “Could not get lock /var/lib/dpkg/lock” – Florian Diesch Oct 28 '12 at 18:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.