Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.10 on an Apple MacBook Pro 9,1 Mid 2012 15inch non retina. Suspend suspends it but when I open the lid, it doesn't wake up. I tried pressing Ctrl + Alt + F1 but nothing works. Only the keyboard backlight switches on. What's the issue?

Moreover, I'm using the X org nouveau driver and not the official nVidia one. Please help. It is irritating to shut the laptop down every time.

share|improve this question
add comment

3 Answers

Preferably try to fix your Hibernation function if its not working too. because in similar cases with "sleep problem",seems hibernate is more handy and workable solution.refer to this post

  • Test pci=noacpi as a boot parameter
  • take a look at /etc/default/acpi-support , probably it needs some changes
  • and if you are lucky, this command can help you:

    sudo chmod +x /etc/pm/sleep.d/*

all in all,it looks like this kind of troubles is related to hardware thing (Graphic Driver incompatibility or Power Manager) so why you don't try appropriate NVidia driver for your OS distribution?

share|improve this answer
    
Problem is I'm unable to install the nVidia driver askubuntu.com/questions/207578/do-nvidias-drivers-work-in-12-10 Please see my comments about a black screen in one of the answers –  pratnala Dec 15 '12 at 14:17
    
So.. guess its too late to answer! but after I read those comments,I think thats because of nVidia driver you installed.theres much differences between your hardwares but you can disable or change your graphic mode in boot-parameters.theres many documents describe it.change vga modes and find safest you can.I'm going to post some of them –  Amir Reza Adib Mar 19 '13 at 11:24
    
I uninstalled the nvidia drivers after the black screen itself. This question still stands. Will try out your solution. –  pratnala Mar 19 '13 at 16:06
add comment

If you have a live CD try using it and boot-repair tool.seems theres nothing wrong with grub but it's good idea to change some boot options. These are some useful options mentioned by canonical itself..

  • vga=xxx

Set your framebuffer resolution to VESA mode xxx. Check here for a list of possible modes.

  • acpi=off OR noacpi

This parameter disables the whole ACPI system. This may prove very useful, for example, if your computer does not support ACPI or if you think the ACPI implementation might cause some problems (for instance random reboots or system lockups).

  • acpi=force

Activates the ACPI system even if your computer BIOS date is older than 2000. This parameter overrides acpi=off and can also be used with current hardware if the ACPI support is not activated despite apm=off.

  • pci=noacpi OR acpi=noirq

These parameters disable the PCI IRQ routing

  • pci=acpi

This parameter activates the PCI IRQ routing

  • acpi_irq_balance

ACPI is allowed to use PIC interrupts to minimize the common use of IRQs.

  • acpi_irq_nobalance

ACPI is not allowed to use PIC interrupts.

  • acpi=oldboot

Deactivates the ACPI system almost completely; only the components required for the boot process will be used.

  • acpi=ht

Deactivates the ACPI system almost completely; only the components required for hyper threading will be used.

  • noapic

Disable the "Advanced Programmable Interrupt Controller (APIC)".

  • nolapic

Disable the "local APIC".

  • apm=off OR noapm

Disable the Advanced Power Management.

  • irqpoll

Changes the way the kernel handles interrupt calls (set it to polling). Can be useful in case of hardware interrupt issues.

  • acpi.power_nocheck=1 OR acpi_osi=linux

Disable the check of power state or changes the OS compatibility reported to the BIOS. Necessary on some broken BIOSes to make temperature/fan control work.

refer to this https://help.ubuntu.com/community/BootOptions

share|improve this answer
add comment
up vote 0 down vote accepted

On Ubuntu 13.04 and above, sleep and wake up works perfectly once you install NVIDIA's drivers. They don't work on the nouveau drivers.

share|improve this answer
add comment

protected by Community Nov 13 '12 at 23:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.