Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a new laptop which came pre-installed with Windows 7. I love working on Ubuntu and hence installed 12.04 on my laptop. I can work on Windows for 6 hours at a stretch and feel the laptop being only slightly warm, but 15 minutes into running Ubuntu and my laptop is too hot.

The battery also drains out very quickly on Ubuntu. 1.5 hrs of backup on Ubuntu compared to 5-6 hrs on Windows.

I previously owned a Dell Inspiron N5010 and everything ran smoothly on that. No heating issues. It came with Intel i3 processor. So I'm wondering whether this problem has something to do with the processor? (AMD A8)

Specs:

  • HP Pavilion G6-2005AX Laptop (APU Quad Core A8/ 4GB/ 500GB/ Win7 HB/ 1.5GB Graph)
  • 1 GB AMD Radeon HD 7670M Dedicated 512 MB AMD Radeon HD 7640G Graphics Integrated

I've already installed ATI proprietary drivers suggested by Ubuntu. But sensors temperature is 70 deg C.

Is there any fix for this problem?

share|improve this question
1  
Try this: askubuntu.com/questions/208093/samsung-series-5-overheating/… The answer isn't device specific. it works like a charm. –  Dr_Bunsen Oct 29 '12 at 14:15
    
Note that Jupiter (the link in the above comment) does not work nor is available anymore for recent (>=13.10) Ubuntu releases. –  Rmano Mar 17 at 14:31
add comment

3 Answers

OP reported in Revision 2 of the question that he managed to solve the problem:

Managed to fix the problem by installing AMD proprietary drivers downloaded from AMD website, after deactivating the driver suggested by Ubuntu!

Right now the sensors temperature is 47deg C! and battery backup of 4 hrs! HOORAY!

share|improve this answer
add comment

Solution/workaround with open-source drivers: (kernels>=3.11)

I had the same problem; my laptop will even shutdown itself for overheating few minutes after the boot (and sometime it didn't even manage to finish the boot).

My machine Samsung Chronos 7 (see note (3)) with hybrid graphics:

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series]

switching to proprietary drivers helped, but sometime it was overheating too. With open-source drivers, often it didn't arrive to finish the boot. I managed to fix it and use the open-source drivers in Ubuntu 13.10, kernel 3.11.x.

Disclaimer: I do not mind having reduced 3D performance. If you mind it, try installing the latest proprietary drivers.

a) go back to open-source drivers by removing all fglrx packages (link, link). Be sure to remove /etc/X11/xorg.conf if you have one --- it can block open-source drivers to find screens.

b) fundamental add the kernel boot parameter radeon.dpm=1 (see note 1). This alone keeps the temperature down (although higher than I like).

c) Identify the card number (see note 2). In my case is card1, you can say it looking if a file named /sys/class/drm/card1/device/power_dpm_state exists. Go superuser in a terminal with sudo -i and do

echo battery > /sys/class/drm/card1/device/power_dpm_state

this make my GPU 20 degrees (C) colder. I added this to my /etc/rc.local:

# avoid overheating of the AMD GPU
if [ -f /sys/class/drm/card1/device/power_dpm_state ]; then
      echo battery > /sys/class/drm/card1/device/power_dpm_state
fi

d) After suspend/resume, strangely, the GPU is hotter. A solution is to issue (as above in a superuser terminal)

echo low > /sys/class/drm/card1/device/power_dpm_force_performance_level

Interesting links:


Footnotes:

(1) This will enable "dynamic power management" for the radeon driver. FWIK, it will be the default setting in 14.04 and up, so this hack should become obsolete soon.

Main link: https://wiki.archlinux.org/index.php/ATI#Dynamic_power_management

(2) Note that sometime the AMD card changes number across reboots. As a solution I have put in my scripts (I had to put it as is in /etc/rc.local and a similar concoction in a resume script in /etc/pm/sleep.d/01-stay-cool --- comment or read here if you need assistance for the resume script).

# avoid overheating of the AMD GPU
if [ -f /sys/class/drm/card1/device/power_dpm_state ]; then
      echo battery > /sys/class/drm/card1/device/power_dpm_state
      echo low > /sys/class/drm/card1/device/power_dpm_force_performance_level
fi
if [ -f /sys/class/drm/card0/device/power_dpm_state ]; then
      echo battery > /sys/class/drm/card0/device/power_dpm_state
      echo low > /sys/class/drm/card0/device/power_dpm_force_performance_level
fi

(3) Exact model for being google friendly (sudo dmidecode):

System Information
        Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
        Product Name: 700Z3A/700Z4A/700Z5A/700Z5B
        Graphic card Radeon HD 6400M/7400M Series
        Version: 0.1

share|improve this answer
add comment

Got the same problem with both Ubuntu 12.04 and 13.04 on my Sony Vaio SVE1512W1ESI laptop with an AMD Radeon HD 7500M/7600M card. Fan was running all the time and the sensors tool showed temperatures in 60s (started with 56-57 and then went to 67-68 with e.g. browser opened).

Installed proprietary drivers from System Settings -> Additional Drivers but didn't help. Finally installed proprietary driver from AMD's website and it fixed the problem.

Followed the following simple steps to install it (as described in the installation instructions manual found on the same webpage):

  1. sudo sh ./amd-driver-installer-catalyst-13-4-x86.x86_64.run
  2. Chose first option ("Install driver XX on X.Org XX") and next chose "Automatic"
  3. sudo /usr/bin/aticonfig --initial
  4. Rebooted
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.