Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual-head setup: a "main" screen at 1920X1080, and a "secondary" screen to the right of it, rotated at 90 degrees counter-clockwise. Until Friday (26.10.2012), everything was working fine, however on that day an update has caused the rotation settings in xorg.conf to be ignored.

Specifically, I had used the rotation attribute (like in this question). Also, since I have Xinerama enabled, I don't have access to xrandr and the corresponding GUI settings (due to this bug, I think).

What should I change in my xorg.conf to have the second screen rotated again?

Here's my current xorg.conf (the third screen is a monitor built in into the laptop, disabled since my video card can only support 2 outputs). I haven't removed any comments to provide a possible forensic trace.

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.37  (buildd@allspice)  Sun Sep  9 05:59:26 UTC 2012

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#
#    # generated from default
#    Identifier     "Mouse0"
#    Driver         "mouse"
#    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"
#EndSection
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#Section "InputDevice"
#
#    # generated from default
#    Identifier     "Keyboard0"
#    Driver         "kbd"
#EndSection

Section "ServerLayout"

# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#    InputDevice    "Keyboard0" "CoreKeyboard"
# commented out by update-manager, HAL is now used and auto-detects devices
# Keyboard settings are now read from /etc/default/console-setup
#    InputDevice    "Mouse0" "CorePointer"
# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "true"
# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "1"
# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "1"
# Removed Option "Xinerama" "0"
    Identifier     "Layout0"
    Screen      0  "Screen0" 1920 0
    Screen      1  "Screen1" LeftOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "1"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SyncMaster"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor2"
    VendorName     "Unknown"
    ModelName      "Samsung SMBX2235"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Samsung SMBX2235"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 330M"
    Option         "RandRRotation" "on"
    BusID          "PCI:2:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device2"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 330M"
    Option         "RandRRotation" "on"
    BusID          "PCI:2:0:0"
    Screen          2
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 330M"
    Option         "RandRRotation" "on"
    BusID          "PCI:2:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "TwinView" "1"
# Removed Option "metamodes" "DFP-0: 1366x768_60 +277+1080, DFP-1: 1920x1080 +0+0; DFP-0: 1024x768 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 1024x768i +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 960x540 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 840x525 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 832x624 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 800x600 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 800x600_75 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 800x600_72 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 800x600_60 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 800x600_56 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 800x512 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 720x450 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 720x400 +0+1080, DFP-1: nvidia-auto-select +0+0; DFP-0: 700x525 +0+1080, DFP-1: nvidia-auto-select +0+0"
# Removed Option "TwinView" "0"
# Removed Option "TwinViewXineramaInfoOrder" "CRT-0"
# Removed Option "metamodes" "CRT: 1440x900 +0+0"
# Removed Option "TwinView" "1"
# Removed Option "metamodes" "DFP-0: nvidia-auto-select +277+1080, DFP-1: 1920x1080 +0+0; DFP-1: 1024x768i +0+0; DFP-1: 960x540 +0+0; DFP-1: 840x525 +0+0; DFP-1: 832x624 +0+0; DFP-1: 800x600 +0+0; DFP-1: 800x600_75 +0+0; DFP-1: 800x600_72 +0+0; DFP-1: 800x600_60 +0+0; DFP-1: 800x600_56 +0+0; DFP-1: 800x512 +0+0; DFP-1: 720x450 +0+0; DFP-1: 720x400 +0+0; DFP-1: 700x525 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinViewXineramaInfoOrder" "DFP-1, CRT-0"
    Option         "TwinView" "0"
    Option         "rotate" "cw"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: 1680x1050 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP-1: 1920x1080 +0+0"
    Identifier     "Screen2"
    Device         "Device2"
    Monitor        "Monitor2"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "DFP-1, CRT-0"
    Option         "metamodes" "DFP-1: 1920x1080 +0+0; DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: 1440x900 +0+0"
# Removed Option "TwinViewXineramaInfoOrder" "CRT-0"
# Removed Option "metamodes" "DFP-0: 1366x768_60 +0+0; DFP-0: 1024x768 +0+0; DFP-0: 1024x768i +0+0; DFP-0: 960x540 +0+0; DFP-0: 840x525 +0+0; DFP-0: 832x624 +0+0; DFP-0: 800x600 +0+0; DFP-0: 800x600_75 +0+0; DFP-0: 800x600_72 +0+0; DFP-0: 800x600_60 +0+0; DFP-0: 800x600_56 +0+0; DFP-0: 800x512 +0+0; DFP-0: 720x450 +0+0; DFP-0: 720x400 +0+0; DFP-0: 700x525 +0+0"
# Removed Option "metamodes" "DFP-1: 1920x1080 +0+0; DFP-1: 1024x768i +0+0; DFP-1: 960x540 +0+0; DFP-1: 840x525 +0+0; DFP-1: 832x624 +0+0; DFP-1: 800x600 +0+0; DFP-1: 800x600_75 +0+0; DFP-1: 800x600_72 +0+0; DFP-1: 800x600_60 +0+0; DFP-1: 800x600_56 +0+0; DFP-1: 800x512 +0+0; DFP-1: 720x450 +0+0; DFP-1: 720x400 +0+0; DFP-1: 700x525 +0+0"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "DFP-1, CRT-0"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "DFP-1: 1920x1080 +0+0; DFP-1: 800x600 +0+0; DFP-1: 800x600_75 +0+0; DFP-1: 800x600_72 +0+0; DFP-1: 800x600_60 +0+0; DFP-1: 800x600_56 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection
share|improve this question
    
if you run through your xrandr settings in terminal what does it tell you? –  craigsmith86 Nov 1 '12 at 19:22
    
Calling xrandr without arguments just says "RandR extension missing". I think this is due to the bug I linked to. –  TheTerribleSwiftTomato Nov 1 '12 at 22:07

2 Answers 2

up vote 1 down vote accepted

Well, in the end, the answer was stupidly simple.

cp /etc/X11/xorg.conf ~/xorg.backup
sudo rm /etc/X11/xorg.conf
sudo shutdown -r now

And, after this, I can change the screen layout normally.

share|improve this answer

There are two nvidia driver. One by the community and one by the nvidia folks themselves. Suggest you try both.

I think the community powered drive is called 'nv' and other is 'nvidia' ( or vice versa ). I have done the same in fedora and in some graphics cards community driver used to work better and in latest generation card the company support driver used to work well.

I have done this in Fedora before. ( i have not validated this in Ubuntu ;) )

share|improve this answer
    
Except by the looks of it the NVIDIA driver was not updated before the glitch started to occur. Thanks, 'though. –  TheTerribleSwiftTomato Nov 5 '12 at 21:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.