Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have successfully integrated AD + Samba + Winbind in my Ubuntu NAS box and all worked fine for 2 weeks. Suddenly today I couldn't get into the share and after logging in to the server, I found that the usernames/groups from the AD were not mapped anymore in Linux, but rather the IDs, as seen here:

root@nas:~# ls -la /work/
total 32
drwxrwx---  5 root 10004  4096 Oct 19 14:34 .
drwxr-xr-x 25 root root   4096 Oct 19 14:28 ..
drwxrwx---  3 root 10026  4096 Oct 19 14:35 adm
drwxrwx---  2 root 10004 16384 Oct  1 16:11 lost+found
drwxrwx--- 23 root 10004  4096 Oct 23 11:23 zshare

Which makes me think it's why I get the access denied error when trying to access the share.

What I've tried so far:

  • I can communicate with the DC. If I try wbinfo, I get groups and users for instance.
  • I can "read" the DC by doing "net ads status"
  • I can login into DC by kinit user@MY.DOMAIN

Can anyone kindly point me to some direction here?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.