Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installation of software results in the following error:

Processing triggers for desktop-file-utils ...
Setting up python3-distupgrade (1:0.190.2) ...
Could not import runpy module
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 289, in <module>
    main()
  File "/usr/bin/py3compile", line 283, in main
    process.communicate()
  File "/usr/lib/python3.2/subprocess.py", line 809, in communicate
    self.stdin.close()
IOError: [Errno 32] Broken pipe
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 64, in apport_excepthook
    from apport.fileutils import likely_packaged, get_recent_crashes
  File "/usr/lib/python3/dist-packages/apport/__init__.py", line 4, in <module>
    from apport.report import Report
  File "/usr/lib/python3/dist-packages/apport/report.py", line 12, in <module>
    import subprocess, tempfile, os.path, re, pwd, grp, os
EOFError: EOF read where not expected

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/py3compile", line 289, in <module>
    main()
  File "/usr/bin/py3compile", line 283, in main
    process.communicate()
  File "/usr/lib/python3.2/subprocess.py", line 809, in communicate
    self.stdin.close()
IOError: [Errno 32] Broken pipe
dpkg: error processing python3-distupgrade (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of ubuntu-release-upgrader-core:
 ubuntu-release-upgrader-core depends on python3-distupgrade (= 1:0.190.2); however:
  Package python3-distupgrade is not configured yet.

dpkg: error processing ubuntu-release-upgrader-core (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ubuntu-release-upgrader-gtk:
 ubuntu-release-upgrader-gtk depends on ubuntu-release-upgrader-core (= 1:0.190.2); however:
  Package ubuntu-release-upgrader-core is not configured yet.
 ubuntu-release-upgrader-gtk depends on python3-distupgrade (= 1:0.190.2); however:
  Package python3-distupgrade is not configured yet.

dpkg: error processing ubuntu-release-upgrader-gtk (--configure):
 dependency problems - leaving unconfigured
Setting up geany-common (1.22+dfsg-2) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                No apport report written because the error message indicates its a followup error from a previous failure.
                                Setting up geany (1.22+dfsg-2) ...
Errors were encountered while processing:
 python3-distupgrade
 ubuntu-release-upgrader-core
 ubuntu-release-upgrader-gtk
E: Sub-process /usr/bin/dpkg returned an error code (1)

'sudo dpkg --configure -a didn't solve the problem. How can I fix this?

share|improve this question
add comment

2 Answers 2

If you're getting:

E: Sub-process error (1) after do-release-upgrade

Try these commands below:

sudo
sudo rm -f /var/lib/dpkg/info/initramfs-tools.post*
sudo rm -f /var/lib/dpkg/info/initramfs-tools.pre*
sudo rm -f /var/lib/dpkg/info/bcmwl-kernel-source.post*
sudo rm -f /var/lib/dpkg/info/bcmwl-kernel-source.pre*
sudo dpkg --configure -a 

I hope this helps you!

share|improve this answer
add comment
up vote 0 down vote accepted

Removing python solved the problem. Reïnstalling python gave the same error. While I do not use python3 I do not mind. But it seems a bug to me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.